Closed Bug 1500484 Opened 1 year ago Closed 1 year ago

widget/gtk/nsClipboardWayland.cpp:32: fatal error: sys/epoll.h: No such file or directory

Categories

(Core :: Widget: Gtk, defect)

Unspecified
FreeBSD
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- fixed
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: jbeich, Assigned: jbeich)

References

Details

(Keywords: regression, Whiteboard: [npotb])

Attachments

(2 files)

$ c++ -v
FreeBSD clang version 7.0.0 (tags/RELEASE_700/final 342383) (based on LLVM 7.0.0)
Target: x86_64-unknown-freebsd12.0
Thread model: posix
InstalledDir: /usr/bin

$ ./mach bootstrap
$ echo "ac_add_options --enable-default-toolkit=cairo-gtk3-wayland" >>.mozconfig
$ ./mach build
[...]
In file included from obj-x86_64-unknown-freebsd12.0/widget/gtk/Unified_cpp_widget_gtk1.cpp:74:
In file included from widget/gtk/nsClipboardWayland.cpp:32:
obj-x86_64-unknown-freebsd12.0/dist/system_wrappers/sys/epoll.h:3:15: fatal error:
      'sys/epoll.h' file not found
#include_next <sys/epoll.h>
              ^~~~~~~~~~~~~
1 error generated.
Summary: Wayland support fails to build on FreeBSD → widget/gtk/nsClipboardWayland.cpp:32: sys/epoll.h:3:15: fatal error: sys/epoll.h: No such file or directory
Summary: widget/gtk/nsClipboardWayland.cpp:32: sys/epoll.h:3:15: fatal error: sys/epoll.h: No such file or directory → widget/gtk/nsClipboardWayland.cpp:32: fatal error: sys/epoll.h: No such file or directory
Attached patch v1Splinter Review
https://treeherder.mozilla.org/#/jobs?repo=try&revision=540a91b9580354f23a76acd72f4ac3e7d6c575f7
Assignee: nobody → jbeich
Attachment #9018657 - Flags: review?(stransky)
Attached patch v1 (esr60)Splinter Review
Rebased in case of backport. Only context lines changed.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=d884084eac9239b0e78266bd8b285f4d53f6cb7d
Comment on attachment 9018657 [details] [diff] [review]
v1

Looks good, Thanks.
Attachment #9018657 - Flags: review?(stransky) → review+
I'd be fine uplifting this to Fx64/ESR60.4, but it's too late for 63 at this point. Feel free to nominate this for Beta/ESR60 approval after it lands on m-c.
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/422dcc2a11ca
Unbreak Wayland build on FreeBSD after bug 1417890. r=stransky
https://hg.mozilla.org/mozilla-central/rev/422dcc2a11ca
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Comment on attachment 9018663 [details] [diff] [review]
v1 (esr60)

[ESR Uplift Approval Request]

If this is not a sec:{high,crit} bug, please state case for ESR consideration: Facilitate regression tracking against patched downstream builds. Also help building Tor Browser which is based on ESR.

User impact if declined: Broken build with Wayland support enabled on non-Linux.

Fix Landed on Version: 64

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Can only break build on Linux. However, Wayland isn't enabled on automation yet.

String or UUID changes made by this patch: 

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1417890

User impact if declined: Broken build with Wayland support enabled on non-Linux.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Can only break build on Linux. However, Wayland isn't enabled on automation yet.

String changes made/needed:
Attachment #9018663 - Flags: approval-mozilla-release?
Attachment #9018663 - Flags: approval-mozilla-esr60?
Comment on attachment 9018663 [details] [diff] [review]
v1 (esr60)

Oops, wrong attachment and wrong flag.
Attachment #9018663 - Flags: approval-mozilla-release?
Comment on attachment 9018657 [details] [diff] [review]
v1

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1417890

User impact if declined: Broken build with Wayland support enabled on non-Linux.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Can only break build on Linux. However, Wayland isn't enabled on automation yet.

String changes made/needed:
Attachment #9018657 - Flags: approval-mozilla-beta?
(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #6)
> https://hg.mozilla.org/mozilla-central/rev/422dcc2a11ca
> Target Milestone: --- → mozilla65

hg.mozilla.org shows milestone 64.0a1 but https://hg.mozilla.org/releases/mozilla-beta/file/tip/widget/gtk/nsClipboardWayland.cpp still has <sys/epoll.h> which confirms it landed in Firefox 65. Kinda confusing.
(In reply to Jan Beich from comment #10)
> hg.mozilla.org shows milestone 64.0a1 but
> https://hg.mozilla.org/releases/mozilla-beta/file/tip/widget/gtk/
> nsClipboardWayland.cpp still has <sys/epoll.h> which confirms it landed in
> Firefox 65. Kinda confusing.

That's because we bump the version on m-c first, but most patches land on integration branches first, so the version can be a bit odd depending on when they first saw the version bump commit.
Comment on attachment 9018657 [details] [diff] [review]
v1

NPOTB bustage fix for downstream distros using Wayland. Approved for 64.0b4.
Attachment #9018657 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 9018663 [details] [diff] [review]
v1 (esr60)

Approved for the next ESR60-based release too (either 60.3.1 or 60.4.0, depending on whatever we end up building next).
Attachment #9018663 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
You need to log in before you can comment on or make changes to this bug.