QuantumBar: Handle loading of non-urls entered in the address bar correctly

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P1
normal
RESOLVED FIXED
8 months ago
6 months ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

(Blocks 1 bug)

Trunk
Firefox 66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

8 months ago
This is to implement the functionality that looks at text entered on the address bar (e.g. via paste and go) and works out if it is a keyword or simple search and gets the loads the appropriate URL.

This looks like we need to uncomment the getShortcutOrURIAndPostData section in UrlbarController.handleEnteredText and get it working correctly.

We may need to move getShortcutOrURIAndPostData to a .jsm, and there may be other structural changes required depending on the outcome of bug 1500483.
Assignee

Updated

8 months ago
Assignee: nobody → standard8
Status: NEW → ASSIGNED
Priority: P2 → P1
Assignee

Updated

7 months ago
No longer blocks: quantumbar-controller
Blocks: 1512652

Comment 2

6 months ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6745799b8cbf
QuantumBar: Handle loading of non-urls entered in the new address bar. r=dao
Assignee

Comment 4

6 months ago
Confirmed on irc that these failures aren't related to my push.
Flags: needinfo?(standard8)

Comment 5

6 months ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/007bbc7c20ef
QuantumBar: Handle loading of non-urls entered in the new address bar. r=dao

Comment 6

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/007bbc7c20ef
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.