browser_contextmenu_linkopen.js doesn't wait for focus/activate events and can therefore manage to open and close a window, and only then get their focus/activate events, breaking popup opening

RESOLVED FIXED in Firefox 65

Status

()

enhancement
P1
normal
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

(Blocks 1 bug)

Trunk
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 wontfix, firefox65 fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1499234 +++

This uses waitForNewWindow - seems reasonable to just make the helper do the waiting, assuming that doesn't break stuff.

Try push with a fix to see if unrelated stuff fails:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=eb74e36e627ab9b3e197cd335843ab405e761de9


The breakage in the test when removing about:blank stuff otherwise ( https://treeherder.mozilla.org/#/jobs?repo=try&revision=6fe4dffa507f64d3f8e51ed7f11f1c2ad0505158&selectedJob=206120788 ) is effectively caused by the deactivation/blurring of the original window calling 'rollup' for all open popups, which breaks opening the popup (if it happens between popupshowing and popupshown).

This is effectively pretty much the same as bug 1499234 except for waitForNewWindow instead of openNewBrowserWindow.

(And yes, perhaps we should unify these 2 things somehow, making openNewBrowserWindow rely on waitForNewWindow, but I'd rather not try to do that in this bug as there may be unrelated fallout).
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e4d47f8261f7
wait for focus and activate of new windows in BTU.waitForNewWindow, r=dao
https://hg.mozilla.org/mozilla-central/rev/e4d47f8261f7
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Depends on: 1501079
Depends on: 1502982
You need to log in before you can comment on or make changes to this bug.