Closed Bug 1500885 Opened Last year Closed Last year

mTextAlignTrue / mTextAlignLastTrue are write-only.

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(3 files)

No description provided.
They were added in bug 929991, but there's no text-align: true anymore.
I think 'true' has been renamed to 'unsafe' at https://drafts.csswg.org/css-align-3/#overflow-values .  Also see bug 969106.
Summary: mTextAlignTrue / mTextAlingLastTrue are write-only. → mTextAlignTrue / mTextAlignLastTrue are write-only.
(and this is really a duplicate of the latter)
I think that given we no longer have style system support for this at all (since bug 1388949 was never fixed), and that the implementation is relatively simple, we should just remove it for now.
I think it's fine to remove it for now.
Neither css-text-3/4 mentions true/unsafe anymore.
https://drafts.csswg.org/css-text-3/#text-align-property
https://drafts.csswg.org/css-text-4/#text-align-property
(for the second bit)
Keywords: leave-open
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/9a97be306a98
mTextAlignTrue / mTextAlingLastTrue are write-only. r=mats
Also remove specified-value-only keywords, since those are handled
only in Rust code and C++ doesn't need to know about them.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/35c3b881583a
Serialize text-align with Servo. r=xidorn
https://hg.mozilla.org/integration/autoland/rev/0dac7f40ea5f
Remove some unused keywords. r=xidorn
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/5ddf191431a9
Remove tests and other similar bits. r=mats
Keywords: leave-open
https://hg.mozilla.org/mozilla-central/rev/5ddf191431a9
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.