Closed Bug 1501182 Opened 11 months ago Closed Last month

Expose the landmark role on elements that have a WAI-ARIA landmark role

Categories

(Core :: Disability Access APIs, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox65 --- wontfix
firefox70 --- fixed

People

(Reporter: MarcoZ, Assigned: MarcoZ)

References

(Blocks 2 open bugs)

Details

(Keywords: parity-chrome)

Attachments

(1 file)

The new WAI-ARIA 1.1 landmark role mapping should be applied to banner, complementary, contentinfo, form, main, navigation, region if the element also has an accessible name, and search.
Depends on: 1501273
Depends on: 1501353
Currently, firefox assigns a "banner" role to <header> element regardless of whether it appears nested in another landmark. Per updated landmark role mapping: 

https://www.w3.org/TR/2017/NOTE-wai-aria-practices-1.1-20171214/examples/landmarks/HTML5.html

header: banner when in context of the body element. The header element is not a banner landmark when it is a descendant of the following HTML5 sectioning elements:

    article
    aside
    main
    nav
    section
(In reply to laura2342 from comment #1)
> Currently, firefox assigns a "banner" role to <header> element regardless of
> whether it appears nested in another landmark. Per updated landmark role
> mapping: 
> 
> https://www.w3.org/TR/2017/NOTE-wai-aria-practices-1.1-20171214/examples/
> landmarks/HTML5.html
> 
> header: banner when in context of the body element. The header element is
> not a banner landmark when it is a descendant of the following HTML5
> sectioning elements:
> 
>     article
>     aside
>     main
>     nav
>     section

Thanks Laura, this is a separate issue, and I will file a bug for it shortly. One additional question, though, does this apply to footer, too? Right now, header and footer elements get the same treatment as for whether they should be treated as landmark elements or not. If footer is different, e. g. it *is* allowed inside such other landmarks, we'll need to separate them.
Flags: needinfo?(laura2342)
Yes- same idea for the footer; if the footer is nested it shouldn't have contentinfo applies as a landmark.
Flags: needinfo?(laura2342)
Duplicate of this bug: 1407287
Duplicate of this bug: 945907
Depends on: 1572512
Blocks: 1572512
No longer depends on: 1572512

(In reply to laura2342 from comment #1)

Currently, firefox assigns a "banner" role to <header> element regardless of
whether it appears nested in another landmark. Per updated landmark role
mapping:

https://www.w3.org/TR/2017/NOTE-wai-aria-practices-1.1-20171214/examples/
landmarks/HTML5.html

header: banner when in context of the body element. The header element is
not a banner landmark when it is a descendant of the following HTML5
sectioning elements:

article
aside
main
nav
section

For completeness, this was dealt with in bug 1573750.

Keywords: parity-chrome
Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3769178b9a30
Expose WAI-ARIA landmarks as landmark roles through accessibility APIs, r=Jamie
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.