Closed Bug 1501255 Opened 3 years ago Closed 1 year ago

Facebook login is not performed on web.12min.com while Tracking Protection Basic is enabled

Categories

(Web Compatibility :: Desktop, defect, P5)

Firefox 65
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1226498

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-social])

User Story

facebook.com

Attachments

(1 file)

[Environment:]
Browser / Version: Firefox Nightly 64.0a1 (2018-10-22) 
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled.
[Steps to Reproduce:]
    1. Navigate to https://web.12min.com/sign-in# 
    2. Click the “Login with Facebook” button.
       
[Expected Behavior:]
Sign is performed.
 
[Actual Behavior:]
Sign is not performed.
The issue is related to `Login` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “https://www.googletagmanager.com/gtm.js?id=GTM-WWX5KW” was blocked because content blocking is enabled.
The resource at “https://connect.facebook.net/en_US/sdk.js” was blocked because content blocking is enabled.
The resource at “https://platform.twitter.com/widgets.js” was blocked because content blocking is enabled.
The resource at “https://api.segment.io/v1/p” was blocked because content blocking is enabled.
The resource at “https://cdn.mxpnl.com/libs/mixpanel-2-latest.min.js” was blocked because content blocking is enabled.
The resource at “https://www.google-analytics.com/analytics.js” was blocked because content blocking is enabled.

So below are the domains to test:
- ​www.googletagmanager.com
- ​connect.facebook.net
- ​platform.twitter.com
- ​api.segment.io
- ​cdn.mxpnl.com
- ​www.google-analytics.com

I opened the URL in a fresh browser profile (Firefox Nightly 64, uMatrix installed, normal mode) and loaded the page. The "Login with Facebook" is not functional.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- facebook.com (including all related domains)
and the "Facebook" permission window is displayed (without uMatrix).

I've set set dom.disable_window_open_feature.toolbar to true in about:config to enabled uMatrix on the window. 

In the main page I also whitelisted:
- facebook.net (including all related domains)
- 12min.com.br (including all related domains)
and the sign in is performed.

The other resources didn't help. 

So in conclusion:
- facebook.com is in "Disconnect" list in "Social" category = [tp-social]
- 12min.com.br is not listed
Attached image uMatrixResults.jpg
Added uMatrix results.
Product: Tech Evangelism → Web Compatibility
Priority: -- → P5

This is a dupe of bug 1226498.

FB login on web.12min.com, twitch.tv, and es.wallapop.com now works fine with basic tracking protection, but are broken in strict mode without the potential work-arounds list in that bug (in Twitch's case it's barely worth worrying about since they are currently removing support for FB logins, but still).

As for moviesanywhere.com, it's simply broken for me. Even with strict mode off (or TP entirely) or even in Chrome, after Facebook logs me in, the site still tells me:

youremail@address.com doesn't exist in our system. Log in using a different email or create account.

This is despite me having allowed them access to my email in Facebook while logging in, so it seems like site error to me.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226498
You need to log in before you can comment on or make changes to this bug.