Closed Bug 1501308 Opened 3 years ago Closed 2 years ago

MediaRecorder will pack for ogg even when requesting webm for audio-only cases

Categories

(Core :: Audio/Video: Recording, defect, P2)

64 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1523563

People

(Reporter: sokoldv, Assigned: pehrsons)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Steps to reproduce:

1. Create MediaRecorder with mediaType option set to 'audio/webm;codecs=opus', previously check if it is supported by calling MediaRecorder.isTypeSupported('audio/webm;codecs=opus')
2. Record stream
3. Create blob with selected mimeType
4. Save as file or send to server

Playground to reproduce:
https://jsbin.com/feburopixo/edit?js,console,output


Actual results:

Despite selected mimeType = audio/webm; codecs=opus
(MediaRecorder.mimeType confirms that selected mimeType will be used for encoding)
Actual container is ogg and it can be seen by first bytes of created file :
OggS | OpusHead | ENCODER=Mozilla63.0OggS
------------------------------------------------------
4f67 6753 0002 0000 0000 0000 0000 aa31
0000 0000 0000 8581 490f 0113 4f70 7573
4865 6164 0102 3801 44ac 0000 0000 004f
6767 5300 0000 0000 0000 0000 00aa 3100
0001 0000 0099 0f5f 1101 364f 7075 7354
6167 730f 0000 006c 6962 6f70 7573 2075
6e6b 6e6f 776e 0100 0000 1300 0000 454e
434f 4445 523d 4d6f 7a69 6c6c 6136 332e
304f 6767 5300 00c0 3f00 0000 0000 00aa
3100 0002 0000 0085 265b a612 ff50 cbcf




Expected results:

MediaRecorder should say it does not support audio/webm or record file in audio/webm
Hi,

I'm assigning a component to get an opinion on this issue. 

Another issue I've observed while trying to reproduce on Nightly:
"getUserMedia supported."
"The following error occured: NotAllowedError: The request is not allowed by the user agent or the platform in the current context." 
Indeed while accessing the page (https://jsbin.com/feburopixo/edit?js,console,output) I wasn't asked to grant any permissions to it, nor could I add any permissions after accessing it, however on Release the page asked for microphone access permissions.

Andreas can you take a look at this?
Component: Untriaged → Audio/Video: Recording
Flags: needinfo?(apehrson)
Product: Firefox → Core
Your second issue sounds like bug 1501745. The mime type issue sounds like something I can fix however.

I moved it to a fiddle so I could open the resulting page without an iframe, and so that gUM works: http://fiddle.jshell.net/pehrsons/d7acqtep/show/light/

According to both MediaRecorder and the blob the mimeType is audio/webm, but according to ffprobe it's indeed ogg.
Assignee: nobody → apehrson
Status: UNCONFIRMED → NEW
Rank: 15
Ever confirmed: true
Flags: needinfo?(apehrson)
Priority: -- → P2
Summary: MediaRecorder will create ogg file in webm container despite selected mediaType → MediaRecorder will pack for ogg even when requesting webm for audio-only cases
See Also: → 1512175

This is getting fixed by bug 1523563.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1523563
You need to log in before you can comment on or make changes to this bug.