Closed Bug 1501458 Opened Last year Closed 10 months ago

Accesses to the tracking protection tables in nsUrlClassifierDBService.cpp seem to be dead code

Categories

(Toolkit :: Safe Browsing, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: ehsan, Assigned: dimi)

References

Details

Attachments

(1 file)

I spoke to Francois about this.  The code around https://searchfox.org/mozilla-central/rev/a7f4d3ba4fbfe3efbde832869f1d672fce7122f6/toolkit/components/url-classifier/nsUrlClassifierDBService.cpp#1572 where we look at TP tables in this file is probably dead code by now and can be removed.  We check for these tables elsewhere already.
Priority: -- → P3
Assignee: nobody → dlee
Status: NEW → ASSIGNED
Priority: P3 → P2
No one is using the aUseTrackingProtection parameter and also tracking
protection related preference in Classify API. And we shouldn't use it
that way in the future.
Pushed by dlee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33e42b897fb1
Remove unused tracking protection code from nsUrlClassifierDBService. r=baku
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Duplicate of this bug: 1510974
You need to log in before you can comment on or make changes to this bug.