Closed Bug 1501605 Opened Last year Closed Last year

Update cubeb from upstream to 04d58b6

Categories

(Core :: Audio/Video: cubeb, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: achronop, Assigned: achronop)

References

Details

Attachments

(1 file)

Pick commits:
04d58b6 osx: close the stream before calling setup (BMO 1500109)
262aea3 doc: update docs for register collection changed callback. Fixes 42
Assignee: nobody → achronop
Blocks: 1500109
Rank: 15
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/73b5fa4feb44
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Alex, do you think we may want to uplift this to beta 64 since it fixed bug 1500109?
Flags: needinfo?(achronop)
Yes we need to uplift it, I have been waiting the fix to be baked on Nightly.
Flags: needinfo?(achronop)
NI to myself for the uplift.
Flags: needinfo?(achronop)
[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1501605

User impact if declined: A sporadic crash when a user join a webrtc call with BT headset

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It works well in Nightly. Also, it's a small fix (one line).

String changes made/needed:
Flags: needinfo?(achronop)
Attachment #9020724 - Flags: review?(kinetik)
Attachment #9020724 - Flags: approval-mozilla-beta?
(In reply to Alex Chronopoulos [:achronop] from comment #6)
> Feature/Bug causing the regression: Bug 1501605

That's this bug. Can you please clarify which bug you meant to say?
Flags: needinfo?(achronop)
Comment on attachment 9020724 [details] [diff] [review]
uplift-cubeb-04d58b6-to-beta.patch

[Triage Comment]
Fixes webrtc crashes while using a BT headset. Approved for 64.0b5.
Attachment #9020724 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I meant to say Bug 1500109. Thanks
Flags: needinfo?(achronop)
That still doesn't make sense. That's the bug this uplift is *fixing*. The question on the form is which bug *caused* the problem.
Flags: needinfo?(achronop)
The problem caused by Bug 1489052.
Flags: needinfo?(achronop)
Attachment #9020724 - Flags: review?(kinetik) → review+
Hmm this does not look right, I think you have uplifted the original patch and not the one nominated for uplift. This is totally fine from runtime execution point of view but it creates confusion in the way we mark changes in this folder. Is it late to backout and re-land the correct one?

I am putting off the uplift request of Bug 1503240 since it will go on the top of that.
Flags: needinfo?(ryanvm)
Flags: needinfo?(ryanvm)
Marking as qe- per comment#6
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.