Closed Bug 1501611 Opened 3 years ago Closed 2 years ago

"Login with Facebook" button label is not displayed while Basic Content Blocking is ON

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 65
Desktop
Windows 10
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1226498

People

(Reporter: sergiu, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-social])

User Story

facebook.net
Environment:
Operating system: Windows 10 Pro
Firefox version: Firefox Nightly 65.0a1 (2018-10-23)  (64-bit)

Prerequisites:
Enable Basic Tracking Protection

Steps to reproduce:
1. Navigate to: https://www.grammarly.com/signin?utm_medium=internal&utm_source=signinHook
2. Observe the "Login with Facebook" button label.

Expected Behavior:
The label is displayed.

Actual Behavior:
an infinite spinner is displayed.

Notes:
1. Screenshot attached: http://prntscr.com/l9t141
This is related to `trackingprotection` breakage #1101005

Looking at the devtools console, here are the blocked resources:

The resource at “https://www.google-analytics.com/analytics.js” was blocked because content blocking is enabled.[Learn More] signin
The resource at “https://www.googletagmanager.com/ns.html?id=GTM-NQ3XB9” was blocked because content blocking is enabled.[Learn More] signin
The resource at “https://connect.facebook.net/en_US/sdk.js” was blocked because content blocking is enabled.[Learn More] signin

So these are the domains to test:
google-analytics.com
googletagmanager.com
connect.facebook.net

I opened the URL in a fresh browser profile (Firefox Nightly 63, uMatrix installed, normal mode) and loaded the page. The tags did not load.

I disabled the Spoof Referrer option in uMatrix and then *WHITELISTED*:
connect.facebook.net

After this, the tags were displayed.
The other resources didn't help.

http://prntscr.com/l9tao0

facebook.net can be found in the disconnect-blacklist.json, disconnect-entitylist.json and disconnect_mapping.py.

So in conclusion:
facebook.net - Social = [tp-social]
Product: Tech Evangelism → Web Compatibility

This is effectively a dupe of bug 1226498, and the proposed work-around in that bug un-breaks the button here.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226498
You need to log in before you can comment on or make changes to this bug.