Closed Bug 1501647 Opened 3 years ago Closed 3 years ago

Crash in js::Scalar::byteSize

Categories

(Core :: JavaScript Engine, defect)

63 Branch
Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1499020

People

(Reporter: pascalc, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-d41dc4e9-6215-4a38-96c7-cae350181024.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll static unsigned __int64 js::Scalar::byteSize js/src/jsfriendapi.h:1543
1 xul.dll js::GetArrayBufferViewLengthAndData js/src/vm/ArrayBufferObject.cpp:2106
2 xul.dll unsigned char* mozilla::dom::CryptoBuffer::Assign dom/crypto/CryptoBuffer.cpp:61
3 xul.dll void mozilla::dom::AesTask::Init dom/crypto/WebCryptoTask.cpp:581
4 xul.dll void mozilla::dom::AesTask::AesTask dom/crypto/WebCryptoTask.cpp:506
5 xul.dll mozilla::dom::WebCryptoTask::CreateEncryptDecryptTask dom/crypto/WebCryptoTask.cpp:3233
6 xul.dll mozilla::dom::SubtleCrypto::Decrypt dom/base/SubtleCrypto.cpp:69
7 xul.dll static bool mozilla::dom::SubtleCrypto_Binding::decrypt dom/bindings/SubtleCryptoBinding.cpp:5594
8 xul.dll static bool mozilla::dom::SubtleCrypto_Binding::decrypt_promiseWrapper dom/bindings/SubtleCryptoBinding.cpp:5608
9 xul.dll mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy, mozilla::dom::binding_detail::ConvertExceptionsToPromises> dom/bindings/BindingUtils.cpp:3296

=============================================================
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1499020
You need to log in before you can comment on or make changes to this bug.