Can't paste long text into textarea of form

VERIFIED DUPLICATE of bug 56219

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 56219
17 years ago
4 months ago

People

(Reporter: toni, Assigned: alexsavulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla does not allow me to paste long enough text to textarea of a form.

This is extremely annoying when trying to copy&paste a spam from mail client to
Spamcop's form. It works with Netscape 4.x and IE.

I have not tested what is the maximum allowed size, I'll leave it up to you...

Versions:
 mozilla-1.0.0-9
 galeon-1.2.5-1
 redhat-release-7.3-1
 gnome-core-1.4.0.4-54
Some more information to debug this...

It seems that if amount of data in copy/paste buffer exceeds X bytes, Mozilla
ignores the new data when I focus to Mozilla window. Instead Mozilla keeps _old_
data in it's own buffer, the data it had there from some earlier copy/paste.

Someone who knows about how Mozilla handles copy buffers in X environment should
comment on this...
Severity: critical → major
Is bug 86262 relevant here ?
comment #2: no, I don't think so.

the buffer seems to be 4000 bytes big. (did a lot of wc -c'ing and
copy/pasting). This certainly isn't a formcontrol bug.. 


*** This bug has been marked as a duplicate of 56219 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verifying
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.