Closed Bug 1502062 Opened 1 year ago Closed 1 year ago

[win 10] exiting fullscreen not respecting original window position

Categories

(Core :: Widget: Win32, defect)

64 Branch
Unspecified
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- fixed
firefox65 --- verified

People

(Reporter: Shadowized, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: parity-chrome, parity-edge, regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

When I exit from a fullscreen video it doesn't respect the position or size of my browser window, resulting in tiled windows being overlapped, as well as firefox by itself if positioned to the edges of the screen (not snapped) being forced inward by about 10px on the top, bottom, and right.

I've tested this extensively in a fresh Windows 10 VM with a clean firefox profile and was able to replicate it 100% of the time. by testing various builds, I've narrowed the regression range down to between https://hg.mozilla.org/mozilla-central/rev/17f44e6e8f490d93e8846e0c611665203eb0a942 (no problems) and https://hg.mozilla.org/mozilla-central/rev/3632445ae3db388e7b214b83acec5a042391a7bb (when this issue started occurring), upon checking the changes in that range (https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=17f44e6e8f49&tochange=3632445ae3db) I believe bug 1473816 is the cause of it but I'm not 100% positive.


Actual results:

example 1: No edge snapping used, Window positioned in the top-right corner of the screen manually, winds up being shoved inward. This one hurts me the most because on my normal setup I have the window positioned at about 65% width on one of my screens, with 100% of the vertical space being used.
https://webmshare.com/VPmwz

example 2: normal window snapped to the left, with Firefox snapped to the right, restoring from fullscreen causes the browser window to expand by 10px, causing it to overflow onto the other window thus breaking tiling.
https://webmshare.com/oQrBQ

example 2a: another issue I've encountered with the second example is that not only does it expand by 10px, it never stops expanding... what I mean is, for every time you do the transition from fullscreen the browser will gain 10px width every time.
https://webmshare.com/ZQD1d




Expected results:

everything should remain as it was prior to entering fullscreen, like this example:
https://webmshare.com/mwGb8
OS: Unspecified → Windows 10
@:xidorn
Can you please look into this?
Blocks: 1473816
Has Regression Range: --- → yes
Flags: needinfo?(xidorn+moz)
Keywords: regression
I suspect Windows 10's snap expands the window beyond the available desktop area...

I don't have Windows machine to debug anymore, so I guess the best we can do is to just backout bug 1473816, which I guess is probably less important than this.
Flags: needinfo?(xidorn+moz)
Ryan, could you help having someone from softvision try confirming this bug?

And if this indeed an issue, try a build with backout of bug 1473816 in https://treeherder.mozilla.org/#/jobs?repo=try&revision=3444106f5c6fe6b42a5ca249fdd0948bcd4b8340 and see if that would fix this.

Thanks.
Flags: needinfo?(ryanvm)
Flags: needinfo?(ryanvm) → needinfo?(tmaity)
Xidorn, I tried that build you linked (Windows 2012 pgo) and it fixed all the issues I reported in the initial post, hopefully others can confirm.
We've started looking into this and will have an update soon.
Flags: needinfo?(tmaity)
Nice catch.

- managed to reproduce on Win10 with both 64.0b5  and 65.0a1 (2018-10-31);
- for STR comment 0 is clear enough, adjusting flags for it as well;
- cross platform wise: I can confirm it's limited to Win10;

*Ubuntu 16.04, macOS10.13, Win8.1 don't seem to be affected by these issues.
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
Summary: exiting fullscreen not respecting original window position → [win 10] exiting fullscreen not respecting original window position
Fixed by backing out bug 1473816.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Can confirm that the issue is no longer reproducible with the current nighlty build 65.0a1(20181104220100).
Status: RESOLVED → VERIFIED
No longer blocks: 1480928
Duplicate of this bug: 1473816
You need to log in before you can comment on or make changes to this bug.