Closed Bug 1502165 Opened 11 months ago Closed 11 months ago

Crash in audiounit_get_devices_of_type

Categories

(Core :: Audio/Video: cubeb, defect, P2, critical)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: marcia, Assigned: achronop)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-d4e665aa-1cd7-4547-95b6-877670181023.
=============================================================

Small volume Mac regression, might be similar to Bug 1500109: https://bit.ly/2PUzdE7. Earliest crashes seem to go back to 20181015100128. Affects both 10.13 and 10.14.

Top 10 frames of crashing thread:

0  @0x7fff4bb3fcc5 
1  @0x7fff4bb64863 
2 XUL audiounit_get_devices_of_type media/libcubeb/src/cubeb_audiounit.cpp:3415
3 XUL ___ZL37audiounit_collection_changed_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke media/libcubeb/src/cubeb_audiounit.cpp:3464
4  @0x7fff78bbad4e 
5  @0x7fff78bbbdca 
6  @0x7fff78bc211f 
7  @0x7fff78bc2bd7 
8  @0x7fff78bcb083 
9  @0x7fff78dfb61b 

=============================================================
This is a regression from Bug 1498519 (commit 4559815).
Assignee: nobody → achronop
Rank: 15
Priority: -- → P1
Priority: P1 → P2
Fix up for review in cubeb repo: https://github.com/kinetiknz/cubeb/pull/471
Git commit picked:
9a7a551 osx: check null reference before using the string (BMO 1502165).
https://hg.mozilla.org/mozilla-central/rev/028d26d752e3
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Please nominate this for Beta approval when you get a chance.
Blocks: 1498519
Flags: needinfo?(achronop)
[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1498519

User impact if declined: Crash when plug/unplug devices on Mac

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): One line change verified in Nightly

String changes made/needed:
Flags: needinfo?(achronop)
Attachment #9021826 - Flags: review?(apehrson)
Attachment #9021826 - Flags: approval-mozilla-beta?
Attachment #9021826 - Flags: review?(apehrson) → review+
Comment on attachment 9021826 [details] [diff] [review]
uplfift-9a7a551-to-beta.patch

[Triage Comment]
Fixes a possible crash when plugging or unplugging devices on Mac. Approved for 64.0b6.
Attachment #9021826 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1503861
You need to log in before you can comment on or make changes to this bug.