Compacting folders is broken

VERIFIED DUPLICATE of bug 150716

Status

--
major
VERIFIED DUPLICATE of bug 150716
17 years ago
10 years ago

People

(Reporter: xenite, Assigned: naving)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020607
BuildID:    20020607

Sometimes when I try to compact a folder, Mozilla fails to compact it. Mozilla
does display the text "Document: Done" in the status bar, but the Mozilla logo
doesn't stop animating and the file that should have been compacted isn't
compacted at all. Mozilla also fails to delete the nstmp file.

This only seems to happen, if the resulting compacted folder would be larger
than approximately 8 kilobyte.

Since moving more than one message at a time is broken too, I had to manually
drag and drop all messages - one at a time (!) - to a new folder, delete the old
one and then rename the new folder (while Mozilla wasn't running of course) :-(


Reproducible: Always
Steps to Reproduce:
1. pick a folder that contains many messages
2. delete a message in that folder
3. try to compact the folder

Actual Results:  Mozilla doesn't compact the folder

Expected Results:  Mozilla should compact the folder
no blocker
Severity: blocker → major

Comment 2

17 years ago
Similar problem occurs with build 2002060908 on Win2000:

If you click Yes on Mozilla's question if the folders should be compacted, it
never ends. The Mozilla icon keeps going, also the progress indicator in the
status line. The status message stays on "Compacting Folder Inbox...". There
seems to be no disk traffic.
If (after a long time) you close Mozilla and restart Mail, the question about
compacting reappears and there is a folder nstmp.

Updated

17 years ago
QA Contact: gayatri → sheelar

Comment 3

17 years ago
Same here with 2002061008 on Windows 2000

Comment 4

17 years ago
Reassigning to navin.  I checked this on win98 machine with branch build and
compact folders from menu did compact my inbox. This could be on the trunk
builds. I still need to check.  
Assignee: mscott → naving
(Assignee)

Comment 5

17 years ago
worksforme on trunk and branch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
Just checked on the trunk build. It does workforme too.  I checked the auto
compact behavior on 2002-06-10-08 trunk  build on pop inbox which is about 20MB
and compaction did reduce the space.  Worksforme too.  Verifying as worksforme.
Status: RESOLVED → VERIFIED

Comment 7

17 years ago
Well, Worksforme for you guys does not need for everybody ;-) . I confirm that
it does NOT work correctly with trunk 2002061008, on Win2k. When I launch
Compact Folders, it seems to be starting correctly, but NEVER stop (I waited one
hour, and this is on a test account with small folders), the blue and grey
moving thing (can't find the english work, sorry) keeps "moving" all the time.
If I stop and restart mozilla, I get, of course, a remaining nstemp folder that
appears.

Regards, 
(Assignee)

Comment 8

17 years ago
reopening to mark as dup of other compact bug.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 9

17 years ago

*** This bug has been marked as a duplicate of 150716 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.