Closed Bug 1502927 Opened 2 years ago Closed 2 years ago

Remove MediaStream.currentTime

Categories

(Core :: WebRTC: Audio/Video, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: padenot, Assigned: padenot)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, site-compat)

Attachments

(1 file)

This is not specced, and nobody else supports it (or has supported it).
This has never been specced and is unused appart from our tests.
Assignee: nobody → padenot
Rank: 18
Priority: -- → P2
Keywords: site-compat
Attachment #9020833 - Attachment description: Bug 1502927 - Remove MediaStream.currentTime. r?baku,jib → Bug 1502927 - Remove MediaStream.currentTime. r?baku!jib!
Pushed by paul@paul.cx:
https://hg.mozilla.org/integration/mozilla-inbound/rev/db3c2a88f79c
Remove MediaStream.currentTime. r=baku,jib
Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&resultStatus=testfailed%2Cbusted%2Cexception&searchStr=linux%2Cdebug%2Cmochitests%2Ctest-linux32%2Fdebug-mochitest-1%2Cm%281%29&fromchange=db3c2a88f79cb28440f4e13bcf27c5165c6ee060&tochange=4cc1239a7be40e828639a66bfdbdc5c4fdf1d894

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=209866981&repo=mozilla-inbound&lineNumber=3215

Backout link: https://hg.mozilla.org/integration/mozilla-inbound/rev/4cc1239a7be40e828639a66bfdbdc5c4fdf1d894

task 2018-11-05T17:33:13.145Z] 17:33:13     INFO - TEST-PASS | browser/components/resistfingerprinting/test/mochitest/test_reduce_time_precision.html | pref: privacy.resistFingerprinting privacy.reduceTimerPrecision  - ''audioContext.currentTime * 1000' should be rounded to nearest 100 ms; saw 1600 
[task 2018-11-05T17:33:13.146Z] 17:33:13     INFO - Buffered messages finished
[task 2018-11-05T17:33:13.148Z] 17:33:13     INFO - TEST-UNEXPECTED-FAIL | browser/components/resistfingerprinting/test/mochitest/test_reduce_time_precision.html | Looming Test Failure, Additional Debugging Info: Expected Precision: 100 Measured Value: NaN Rounded Vaue: NaN Fuzzy1: NaN Fuzzy 2: NaN 
[task 2018-11-05T17:33:13.149Z] 17:33:13     INFO -     SimpleTest.ok@SimpleTest/SimpleTest.js:275:7
[task 2018-11-05T17:33:13.150Z] 17:33:13     INFO -     isRounded@browser/components/resistfingerprinting/test/mochitest/test_reduce_time_precision.html:74:5
[task 2018-11-05T17:33:13.151Z] 17:33:13     INFO -     testDOM@browser/components/resistfingerprinting/test/mochitest/test_reduce_time_precision.html:187:10
[task 2018-11-05T17:33:13.152Z] 17:33:13     INFO -     async*testDOMRFP@browser/components/resistfingerprinting/test/mochitest/test_reduce_time_precision.html:197:11
[task 2018-11-05T17:33:13.153Z] 17:33:13     INFO -     async*nextTick/<@SimpleTest/AddTask.js:70:34
[task 2018-11-05T17:33:13.154Z] 17:33:13     INFO -     async*nextTick@SimpleTest/AddTask.js:44:10
[task 2018-11-05T17:33:13.155Z] 17:33:13     INFO -     setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:12
[task 2018-11-05T17:33:13.156Z] 17:33:13     INFO -     nextTick@SimpleTest/AddTask.js:40:11
[task 2018-11-05T17:33:13.157Z] 17:33:13     INFO -     setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:12
[task 2018-11-05T17:33:13.158Z] 17:33:13     INFO -     add_task@SimpleTest/AddTask.js:30:7
[task 2018-11-05T17:33:13.159Z] 17:33:13     INFO -     @browser/components/resistfingerprinting/test/mochitest/test_reduce_time_precision.html:142:3
[task 2018-11-05T17:33:13.161Z] 17:33:13     INFO - Not taking screenshot here: see the one that was previously logged
Flags: needinfo?(padenot)
Pushed by paul@paul.cx:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ecfc20c69e83
Remove MediaStream.currentTime. r=baku,jib
Thanks !
Flags: needinfo?(padenot)
https://hg.mozilla.org/mozilla-central/rev/ecfc20c69e83
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Noted in Firefox 65 for developers; never mentioned anywhere else on MDN previously. Never in BCD. That's it for this update.
Duplicate of this bug: 1166883
You need to log in before you can comment on or make changes to this bug.