Closed Bug 1502943 Opened 2 years ago Closed 2 years ago

"Blocking" label disappears when Content Blocking is disabled on a site

Categories

(Firefox :: Site Identity, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox63 - unaffected
firefox64 - wontfix
firefox65 - wontfix

People

(Reporter: ehsan, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

1. Disable Content Blocking on a site by selecting "Disable Blocking For This Site" from the control centre.
2. Look in front of the Tracking Cookies line.

Actual Results:

no label is shown.

Expected Results:

Add Blocking/Blocking label must appear here.
Wait, why? We're not blocking. You just disabled it. I think this is on purpose.
Flags: needinfo?(ehsan)
See the screenshot.  If it's expected for "Tracking Cookies" the fact that we show it for "Trackers" is a bug.

(Note that this is a visible change compared to 63 which is why I filed it as a regression.  I don't know what the desired behavior here is, but if this has been an intentional change I've missed why we did it, can you please link to the bug where the change was made with the rationale?)
Flags: needinfo?(ehsan)
(In reply to :Ehsan Akhgari from comment #2)
> See the screenshot.  If it's expected for "Tracking Cookies" the fact that
> we show it for "Trackers" is a bug.
> 
> (Note that this is a visible change compared to 63 which is why I filed it
> as a regression.  I don't know what the desired behavior here is, but if
> this has been an intentional change I've missed why we did it, can you
> please link to the bug where the change was made with the rationale?)

I remember why it's that way now, the dilemma is that "Add Blocking" links to the preferences section, but of course there it's already enabled, so that's not actionable for the user. It's just an exception.

So we can't say "Blocked" (because it's really not blocked) but "Add Blocking" would be misleading, too.

This is also in the old design spec: https://mozilla.invisionapp.com/share/VSMVD99JK6D#/screens. I don't think you'll get more info in the bug that implemented it.

It works the same way for me in 63.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.