Startup crashes with fbplugin on macos

RESOLVED FIXED

Status

defect
--
critical
RESOLVED FIXED
7 months ago
6 months ago

People

(Reporter: philipp, Assigned: gsvelto)

Tracking

({crash, regression})

unspecified
Unspecified
macOS
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 wontfix, firefox64+ fixed, firefox65+ fixed)

Details

(crash signature)

Attachments

(1 attachment)

Reporter

Description

7 months ago
This bug was filed from the Socorro interface and is
report bp-2ecb6ae5-30bb-4bff-b0b3-5118f0181028.
=============================================================

Top 10 frames of crashing thread:

0 CoreFoundation CFBasicHashFindBucket 
1 fbplugin fbplugin@0xeb8 
2 fbplugin fbplugin@0x22e9 
3  @0x118f9fa09 
4  @0x118f9fc39 
5  @0x118f9b16f 
6  @0x118f9a2a5 
7  @0x118f9a339 
8  @0x118f8e3e4 
9  @0x118f97001 

=============================================================

after the update to firefox 63, there's an uptick in startup crashes on various versions of macos with the involvement of "fbplugin", that was already causing problems on other occasions (bug 1086977).

this is currently accounting for close to 10% of browser crashes from macos, though it's hitting individual installations repeatedly.
Reporter

Comment 1

7 months ago
the issue is also coming up on sumo a couple of times:
https://support.mozilla.org/questions/firefox?owner=all&tagged=bug1502977&show=all
Crash Signature: [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] → [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda…
Added a few more signature. I counted a total of about 350 crashes so far, but as philipp notes in Comment 0 some individuals are crashing more than once.
Crash Signature: [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda… → [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda…
Crash Signature: [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda… → [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda…
Duplicate of this bug: 1507896
Crash Signature: [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda… → [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda…
Adding a 10.14 specific signature.
Crash Signature: [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda… → [@ CFDictionaryGetValue] [@ CoreFoundation@0xb634] [@ CFBasicHashFindBucket] [@ CoreFoundation@0xc646] [@ CoreFoundation@0x9596] [@ CoreFoundation@0x863d] [@ CoreFoundation@0xc5f6] [@ CoreFoundation@0xc696] [@ CoreFoundation@0x9606] [@ CoreFounda…
It looks like the plugin block that was introduced in bug 1086977 has been removed (inadvertently?) by bug 1348273.
Flags: needinfo?(gsvelto)
Assignee

Comment 6

6 months ago
Oh gosh, I wanted to update that annotation and change the second part in a proper removal but I must have forgotten about it. Patch coming to put it back.
Flags: needinfo?(gsvelto)
Assignee

Updated

6 months ago
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Reporter

Comment 8

6 months ago
hi jim, is it possible to review this patch soon? it would be very nice to see this uplifted to 64 still (because for a mac issue, it's getting mentioned fairly frequently on SUMO) - but the window where that's possible is closing soon.
Flags: needinfo?(jmathies)

Updated

6 months ago
Flags: needinfo?(jmathies)

Comment 9

6 months ago
Pushed by gsvelto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/646caf2d4577
Reinstate the code blocking the "Facebook Photo Uploader" plugin on Mac and update the associated annotation r=jmathies

Comment 10

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/646caf2d4577
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Want to request uplift?
Flags: needinfo?(gsvelto)
Assignee

Comment 12

6 months ago
Yes, right away
Flags: needinfo?(gsvelto)
Assignee

Comment 13

6 months ago
Comment on attachment 9026230 [details]
Bug 1502977 - Reinstate the code blocking the "Facebook Photo Uploader" plugin on Mac and update the associated annotation

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1348273

User impact if declined: Firefox crashes on startup

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): The patch only adds back code that was already preventing this problem from happening

String changes made/needed: None
Attachment #9026230 - Flags: approval-mozilla-beta?
Comment on attachment 9026230 [details]
Bug 1502977 - Reinstate the code blocking the "Facebook Photo Uploader" plugin on Mac and update the associated annotation

block crashing plugin, approved for 64.0rc1
Attachment #9026230 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.