If Mozilla crashes, it would be nice to get my context upon next reopen

VERIFIED DUPLICATE of bug 19454

Status

enhancement
VERIFIED DUPLICATE of bug 19454
17 years ago
7 years ago

People

(Reporter: rviragh, Assigned: Matti)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

Mozilla crashed.  I don't care, but I had about seven different windows open,
each with half a dozen to two dozen tabs.  (I catch up on my slashdot in large
spurts).  To my horror, upon reopening Mozilla, it did not give me back my
context!  This is an outrage, and I am going back to Opera.  I'm all for open
source, but you cost me about five-six hours of searching.  If I open a tab for
later viewing, I expect it to STAY open.

Reproducible: Always
Steps to Reproduce:
1.  Do anything to crash Mozilla.
2.  Watch your context disappear.
3.  Curse the development team and go back to Opera.

Actual Results:  lost entire context tree.

Expected Results:  gave me back the same context tree.

How hard is it?  Each time the context changes, you record it.  And another
thing:  if my computer ever crashes or loses power, _I expect my context back
the next time I open Mozilla_!!!!!!!

I'm sorry for the bad attitude, but I'm really **** now.  Later, I'll
apologize.  In fact, I apologize now: sorry.
(Assignee)

Comment 1

17 years ago
not critical = enhancement 
URL is not valid

and a dupe

*** This bug has been marked as a duplicate of 19454 ***
Severity: critical → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
But it's absolutely critical, because I CANNOT USE MOZILLA until it's fixed.  I
don't care what kind of a hack you need to implement to get this done, 19454
suggests an in-depth solution, but I want a down-and-dirty resolution
immediately, or I /cannot/ use Mozilla.  I am not going to manually create a
text file
win1
tab1 http://wasdfasdfsadf
tab2 http://gsfagsdfdsf
etc
win2
tab1 
tab2
etc, 
the way I used to do in Internet Explorer every few days, before I found opera.
Understand this:  I surf with dozens of windows open for DAYS.  Your product is
UNUSABLE to me if I lose my context upon crashes.
And, until this is fixed, I have no choice but to go to Opera.
It is not a "nice enhancement"...it's critical for allowing me NOT TO LOSE DATA.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

17 years ago
critical mean that this is critical for us (mozilla.org) and not critical for you.

The reason for a crash itself is critical.

see also bug 36810

we don't hack a fast-dirty solution.

reduping since this bug is clearly a dupe of bug 36810 or 19454.

Please don't reopen this bug. Thanks for your impression as a mozilla tester 
(mozilla.org has only test builds and is not for End-User)




*** This bug has been marked as a duplicate of 19454 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
v. http://recall.mozdev.org/ may work, I haven't tried it myself
Status: RESOLVED → VERIFIED
(Assignee)

Comment 5

17 years ago
recall is broken with current builds...
Product: Browser → Seamonkey

Updated

7 years ago
QA Contact: imajes-qa
(Reporter)

Updated

7 years ago
Summary: If Mozilla crashes, I DEMAND my context upon next open!!! → If Mozilla crashes, it would be nice to get my context upon next reopen
You need to log in before you can comment on or make changes to this bug.