Status

()

enhancement
RESOLVED FIXED
7 months ago
6 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

unspecified
mozilla65
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox63 fixed, firefox64 fixed, firefox65 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

https://github.com/eqrion/cbindgen/pull/233 changed the way one of the options we use work.

I think the new behavior is better, but we should do this sooner rather than later, and fix broken builds.
Assignee

Comment 1

7 months ago
https://github.com/eqrion/cbindgen/pull/233 changed the way one of the options
we use work.

I think the new behavior is better, but we should do this sooner rather than
later, and fix broken builds.
Assignee

Comment 2

7 months ago
[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: N/A

User impact if declined: None

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Only keeps the build working with newer versions of a build dependency. It should be a no-op in our automation, which uses a fixed older version.

String changes made/needed:
Attachment #9021333 - Flags: approval-mozilla-release?
Assignee

Comment 3

7 months ago
[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: N/a

User impact if declined: None

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): See justification in the previous comment.

String changes made/needed: none
Attachment #9021334 - Flags: approval-mozilla-beta?
Assignee

Comment 4

7 months ago
Tests so this doesn't happen again in https://github.com/eqrion/cbindgen/pull/236.

Comment 5

7 months ago
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/5b0e4820c7fb
Update cbindgen due to breaking change. r=boris

Comment 6

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5b0e4820c7fb
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65

Comment 7

7 months ago
Comment on attachment 9021333 [details] [diff] [review]
Keep mozilla-release building with newer cbindgen versions.

Doesn't appear to help on top of 63.0.1, see https://ptpb.pw/Gm7b (build log). Am I missing more patches?
Assignee

Comment 8

7 months ago
(In reply to Jan Beich from comment #7)
> Comment on attachment 9021333 [details] [diff] [review]
> Keep mozilla-release building with newer cbindgen versions.
> 
> Doesn't appear to help on top of 63.0.1, see https://ptpb.pw/Gm7b (build
> log). Am I missing more patches?

Hmm, let me double-check.
Comment on attachment 9021334 [details] [diff] [review]
Keep mozilla-beta building with newer cbindgen versions.

[Triage Comment]
Updates mozilla-beta to work with newer cbindgen versions. Approved for 64.0b6.
Attachment #9021334 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
Assignee

Comment 11

7 months ago
See comment 2.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: 

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): 

String changes made/needed:
Attachment #9021658 - Flags: approval-mozilla-release?
Assignee

Comment 12

7 months ago
Comment on attachment 9021333 [details] [diff] [review]
Keep mozilla-release building with newer cbindgen versions.

This was missing a comma, d'oh.
Attachment #9021333 - Attachment is obsolete: true
Attachment #9021333 - Flags: approval-mozilla-release?
Comment on attachment 9021658 [details] [diff] [review]
Keep mozilla-release building with newer cbindgen versions.

Updates mozilla-release to work with newer cbindgen versions. Approved for 63.0.3.
Attachment #9021658 - Flags: approval-mozilla-release? → approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.