Missing min-width value in the flex item sizing properties list if min-width comes from the default value

RESOLVED FIXED in Firefox 65

Status

defect
P3
normal
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: pbro, Assigned: mtigley)

Tracking

unspecified
Firefox 65
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

7 months ago
I haven't yet found a simpler test page for this, but here are some not too hard steps to reproduce:

- load https://codepen.io/
- open the inspector
- select the img.projects-screenshot element
- in the rule-view, toggle the max-width:100% property off
- select the div.projects-promo element
- head over to the flex item sidebar panel

--> The Minimum Size section is displayed, but it shows min-width:; (missing value)

This is because clamping on min-width did occur, but min-width was not specified by the author in CSS. It instead came from the browser's default auto value.

I think we shouldn't attempt to display the min-width property at all in this case.
Same thing goes for the Maximum Sizing section.
Assignee

Updated

7 months ago
Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Priority: -- → P3

Comment 3

7 months ago
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d05e436d35b
Only display a flex item's min-width/max-width property if it's specified in the CSS. r=gl

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2d05e436d35b
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.