Closed Bug 150372 Opened 22 years ago Closed 19 years ago

zh-TW Chinese Traditional language pack replaces searchplugins/google.src

Categories

(Core :: Internationalization: Localization, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: electron369, Assigned: piaip)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

I downloaded the Taiwan (language and content pack).
swichet to the pack in Preference, it worked fine , then  
swich back to Englsh (bouth preference). Then went to search in the address box
using google and a taiwan language search came up.  

Reproducible: Always
Steps to Reproduce:
download the taiwan pack
I could not Install the Taiwan language pack. Will try to repro this bug as soon
as bug 171377 is fixed.
Depends on: 171377
Summary: downloaded language and content pack (Tw) → downloaded language and content pack (Tw)
-> Localization 

Please look into this bug and the depending one. I don't think it has anything
to do with search.
Component: Search → Localization
-> tao
Assignee: sgehani → tao
Google has its own settings for language. Are you sure your google cookie isnt'
set to Taiwan search?

Please check this out, and reproduce with a current build.
confirming. The problem is caused by the language code replacing the
"searchplugins/google.src" file
Assignee: tao → piaip
Status: UNCONFIRMED → NEW
No longer depends on: 171377
Ever confirmed: true
QA Contact: claudius → whiteclover79-bug
Summary: downloaded language and content pack (Tw) → zh-TW Chinese Traditional language pack replaces searchplugins/google.src
(In reply to comment #5)
> confirming. The problem is caused by the language code replacing the
> "searchplugins/google.src" file
I'm the maintainer of Traditional Chinese language pack.
Yes, I did changed the google.src. Because there's no method to change/set
default locale and search language so I just changed several default things
so that most people will not get confused after they think they did installed
a language pack. I wonder whether this is a bug or not. If I shouldn't change 
the default google.src, I'll remove it in future releases.
Depends on: 248776
already changed to googletw.src
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.