Perma /fetch-destination.https.html | HTMLLinkElement with rel=prefetch fetches with an empty string Request.destination - expected TIMEOUT when Gecko 65 merges to Beta on 2018-12-03

VERIFIED FIXED in Firefox 65

Status

()

defect
VERIFIED FIXED
10 months ago
9 months ago

People

(Reporter: RaulGurzau, Assigned: mconley)

Tracking

unspecified
mozilla65
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65+ verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

[Tracking Requested - why for this release]:

Regression from Bug 1501044

Central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception&revision=7f1e42a7de915ec3547461676e7fabe9751d8431&selectedJob=209135029

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=209135029&repo=try&lineNumber=6133

Log snippet: 
[task 2018-11-01T11:49:50.862Z] 11:49:50     INFO - TEST-PASS | /fetch/api/request/destination/fetch-destination.https.html | HTMLLinkElement with rel=preload and as=manifest fetches with a "manifest" Request.destination 
[task 2018-11-01T11:49:50.862Z] 11:49:50     INFO - TEST-UNEXPECTED-PASS | /fetch/api/request/destination/fetch-destination.https.html | HTMLLinkElement with rel=prefetch fetches with an empty string Request.destination - expected TIMEOUT
[task 2018-11-01T11:49:50.863Z] 11:49:50     INFO - TEST-INFO | expected TIMEOUT
[task 2018-11-01T11:49:50.864Z] 11:49:50     INFO - TEST-UNEXPECTED-OK | /fetch/api/request/destination/fetch-destination.https.html | expected TIMEOUT
[task 2018-11-01T11:49:50.864Z] 11:49:50     INFO - TEST-INFO expected TIMEOUT | took 2049ms
Component: DOM → web-platform-tests
Product: Core → Testing
From the behavior, it ignores the browser.tabs.remote.separatePrivilegedContentProcess set to true in bug 1501044.
Component: web-platform-tests → DOM: Networking
Flags: needinfo?(mconley)
Product: Testing → Core
Assignee: nobody → mconley
A more robust solution is probably to disable the preloaded about:newtab for this test. That way, it's far less likely to pass accidentally, instead of timing out (which it should be doing, due to bug 1500089.

Beta simulation try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d1d9830ae24a936bbb6e082daadb736cfe3cc7bb

mozilla-central try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=15982c4cbdcf0a3f9e82fb80d2eacae1e021e28d
See Also: → 1500089
Cripes, it still fails. :(

What would be truly lovely is the ability to just _disable_ this subtest, but (unless jgraham can correct me here), there's no way to disable a subtest, right?
Flags: needinfo?(mconley) → needinfo?(james)
The prefetch test is pretty flake-y, and when it passes, it's only by accident.

See bug 1500089 for details.
Yeah, if the test timing out is causing the entire file to time out there isn't a good and easy solution (subtests and the whole file have different statuses). At the moment the only possibilities are 
1) Disable the whole file
2) Move the problematic subset out into a seperate test file and disable that subtest

Obviously the second one is better since we avoid losing coverage for the other tests, but it's also more work.
Flags: needinfo?(james)
Attachment #9027055 - Attachment is obsolete: true
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d534baf41277
Split out prefetch test from fetch-destination.https.html, and disable for Firefox. r=jgraham
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/14244 for changes under testing/web-platform/tests
Can't merge web-platform-tests PR due to failing upstream checks:
Github PR https://github.com/web-platform-tests/wpt/pull/14244
* Taskcluster (pull_request) (https://tools.taskcluster.net/task-group-inspector/#/YtaP2931RwOwwo-RrMtfoQ)
https://hg.mozilla.org/mozilla-central/rev/d534baf41277
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Upstream PR merged
You need to log in before you can comment on or make changes to this bug.