form selected options is not correctly refreshed

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Networking: Cache
--
major
VERIFIED DUPLICATE of bug 46845
15 years ago
13 years ago

People

(Reporter: pajoye, Assigned: gordon)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Hello,

A form with one or many select object, each one has a selected options. Cache
enabled or not, if you reload the page and the selected options has been
changed, nothing change visually. The page is correctly reloaded.

sample form :
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd"><html>
<body>
<form name="test" action="" method="post">
<select name="test">
<option value="-1">dsjks</option>
<option value="1">dsjk1s</option>
<option value="15">15dsjks</option>
<option value="23" selected>d23sjks</option>
</select>
</form>
</body>
</html>
the data doesn't get lost, if you refresh - where's the problem?
(Reporter)

Comment 2

15 years ago
Sorry, I was not very clear. Just try to change the selected option between
reload. Mozilla keeps always the 1st it gets, as well the page has been
correctly loaded (Understood the page is reload, but the select object is not).

Comment 3

15 years ago
you're seeing bug 46845 -- "Form elements don't reset upon reloading page", right?
you can do shift-reload to actually reload everything.

marking dupe.  reopen if you're seeing something else.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
OK, seems to be the same problem. I read the thread and find the tips of shift-r
usefull for enduser.

Maybe when you post something again, mozilla does not have to keep values ? As
far  we should consider a new post as "a new uri" and values should change.

or am i wrong ?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.