Closed Bug 1504155 Opened 4 years ago Closed 2 years ago

Slideshow breaks after reaching an ad on timesnews.net while Tracking Protection Basic is enabled

Categories

(Web Compatibility :: Desktop, defect, P5)

Firefox 65
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: oanaarbuzov, Unassigned)

References

()

Details

(Whiteboard: [tp-ads][tp-content][tp-shim-trivial][tp-site-ephemeral])

User Story

googletagservices.com
doubleclick.net
disqus.com

Attachments

(3 files)

Attached image SlideshowBroken.gif
[Environment:]
Browser / Version: Firefox Nightly 65.0a1 (2018-11-01) 
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled.
[Steps to Reproduce:]
    1. Navigate to http://www.timesnews.net/gallery/Arrested-Sullivan-County-mugshots-Oct-19-26-1 
    2. Vier the slideshow using the arrows.
    3. Observe behavior when an “empty” ad is displayed.
       
[Expected Behavior:]
Slideshow continues to work after dismissing the ad.
 
[Actual Behavior:]
Slideshow breaks and photos can no longer be viewed.
The issue is related to `trackingprotection` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “https://www.googletagservices.com/tag/js/gpt.js” was blocked because content blocking is enabled.
The resource at “http://www.google-analytics.com/analytics.js” was blocked because content blocking is enabled.
The resource at “http://cdn.cxense.com/cx.js” was blocked because content blocking is enabled.
The resource at “http://jadserve.postrelease.com/t?ntv_url=http%3A%2F%2Fwww.timesnews.net%2Fgallery%2FArrested-Sullivan-County-mugshots-Oct-19-26-1” was blocked because content blocking is enabled.
The resource at “http://connect.facebook.net/en_US/sdk.js” was blocked because content blocking is enabled.
The resource at “http://c.amazon-adsystem.com/aax2/apstag.js” was blocked because content blocking is enabled.
The resource at “http://edge.quantserve.com/quant.js” was blocked because content blocking is enabled.
The resource at “http://ad.doubleclick.net/ddm/ad/gqrzlruz/dqqhbwqp/;ord=1541153043176?” was blocked because content blocking is enabled.
The resource at “https://googleads.g.doubleclick.net/pagead/id” was blocked because content blocking is enabled.
The resource at “https://static.doubleclick.net/instream/ad_status.js” was blocked because content blocking is enabled.
The resource at “https://pagead2.googlesyndication.com/pagead/gen_204?rt=third_party&lid=17&sdkv=h.3.0.0&id=ima_html5&c=3471733030553178&domain=www.timesnews.net” was blocked because content blocking is enabled.
The resource at “http://static.criteo.net/js/ld/publishertag.js” was blocked because content blocking is enabled.
The resource at “http://fastlane.rubiconproject.com/a/api/fastlane.json?account_id=13380&site_id=57162&zone_id=584650&size_id=15&p_pos=btf&rp_floor=0.25&rp_secure=0&tk_flint=pbjs_lite_v0.32.0-pre&tid=0310c90a-6288-4283-a583-6762bfc2cc3f&p_screen_res=1920x1080&rand=0.15692348819433544&rf=http%3A%2F%2Fwww.timesnews.net%2Fgallery%2FArrested-Sullivan-County-mugshots-Oct-19-26-1” was blocked because content blocking is enabled.
The resource at “http://ib.adnxs.com/jpt?callback=pbjs.handleAnCB&callback_uid=639dcf47b7787e8&psa=0&id=11252796&size=300x250&referrer=http%3A%2F%2Fwww.timesnews.net%2Fgallery%2FArrested-Sullivan-County-mugshots-Oct-19-26-1” was blocked because content blocking is enabled.
The resource at “https://securepubads.g.doubleclick.net/pcs/view?xai=AKAOjsuPjEjW6b-vISxNavkiw_AKPoIfHS3H3jS4sVms9L_dT79VHOR0Nsf3GlEepzSRPzAR3t7rYPTYTI1L9QjBL5xhpqhuncOQZvNSncbgTkHavOVMp4bR1AWP-5d9rlF0SGItMvdkotbdwCiBEwndE4GP8mPTimi1d1HoGEwtZQJUwl75twWqGboJ3cDml1D6I2pwk8Jb4LRkV_c0r2lockdKSz33sFdASh4Nfddp0Vp3IAvgT7t5v-yN5oG9tPAVzdVC86uFWpY7oDBRJ9w&sig=Cg0ArKJSzFuJfTX9PimUEAE&adurl=” was blocked because content blocking is enabled.
The resource at “http://static.adsnative.com/static/js/render.v2.js” was blocked because content blocking is enabled.

So below are the domains to test:
- www.googletagservices.com
- www.google-analytics.com
- cdn.cxense.com
- jadserve.postrelease.com
- connect.facebook.net
- c.amazon-adsystem.com
- edge.quantserve.com
- ad.doubleclick.net
- googleads.g.doubleclick.net
- static.doubleclick.net
- pagead2.googlesyndication.com
- static.criteo.net
- fastlane.rubiconproject.com
- ib.adnxs.com
- securepubads.g.doubleclick.net
- static.adsnative.com

I opened the URL in a fresh browser profile (Firefox Nightly 65, uMatrix installed, normal mode) and loaded the page. The slideshow is broken load.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- googletagservices.com (including all related domains)
- doubleclick.net (including all related domains)
and the slideshow can be played.

Other elements were broken on the page so I WHITELISTED:
- disqus.com (including all related domains)
- disquscdn.com (including all related domains)
and the comments area and article links are displayed.

The other resources didn't help. 

So in conclusion:
- googletagservices.com is in Disconnect list at Advertising = [tp-ads]
- doubleclick.net is in Disconnect list at Advertising = [tp-ads]
- disqus.com is in Content category = [tp-content]
- disquscdn.com is not listed
User Story: (updated)
Whiteboard: [tp-ads][tp-content]
Attached image uMatrixResults.jpg
Added uMatrix results.
Product: Tech Evangelism → Web Compatibility
Priority: -- → P5

What I get to an "empty" image, I see this in the console:

TypeError: googletag.destroySlots is not a function adb.2283410.min.js:2:113925

Sure enough, https://www.googletagservices.com/tag/js/gpt.js is blocked. If I minimally shim that script that so that googletag.destroySlots() exists, then the arrows work, though there are still "empty" images in the gallery.

If we'd like to try to have some sort of "placeholder" image in place of ads, so users see a "Firefox has blocked a tracker here", we can investigate further.

See Also: → 1477264
No longer blocks: tp-breakage
Whiteboard: [tp-ads][tp-content] → [tp-ads][tp-content][tp-shim-trivial][tp-site-ephemeral]
Attached image GalleryWorks.gif

The article is no longer available and I searched for a slideshow on the site, but the issue no longer occurs, regardless if ETP is Strict or Standard.
URL: https://www.timesnews.net/photo-video/photo-gallery-sullivan-central-sweeps-ths/collection_c643d94a-5e18-11eb-9164-372a827cd4ee.html#4

Tested with:
Browser / Version: Firefox Nightly 87.0a1 (2021-01-25)
Operating System: Windows 10 Pro

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.