Closed Bug 1504175 Opened Last year Closed Last year

Missing repaints on CSS element after a class change (display property)

Categories

(Core :: Web Painting, defect)

63 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1482403

People

(Reporter: javier.rocamora, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

Steps to reproduce:

Weird bug happening only on Firefox (ver 63, OSX). On our homepage https://www.tele2.nl just press any Menu item. 

User Agent string:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0


Actual results:

When pressing a menu item nothing happens. There's a collapsible div that should show, but it doesn't 'paint'. It does when you scroll or resize the window, among other actions. Seems like a performance optimization is in place. In the attached screenshot you can see the problem. The element is there, the links can be clicked, but the content doesn't show until you do certain actions. It's a simple switch from display: none; to display: flex; so it doesn't make sense.

Solutions like disabling hardware acceleration are not valid here. We cannot tell that to all of our users.

I looked into bugs database, but couldn't find anything related. Is this a known bug? Is there some way to avoid it?


Expected results:

In any other browser, there's a collapsible section that shows/hide when pressing those menu items. The click basically adds a CSS class that turns an element from display:none to display:flex.
Hi, I managed to reproduce this issue in Firefox 63.0.1 but I was unable to reproduce this issue in Firefox Nightly 65.0a1 (2018-11-06), here are the results of the mozregression:


INFO: First good revision: 1feb8b3f06e7f93d1cd67d59011074add931b086
INFO: Last bad revision: 202887e7c361b76d8d3c6f5cb261e71042200ad1
INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=202887e7c361b76d8d3c6f5cb261e71042200ad1&tochange=1feb8b3f06e7f93d1cd67d59011074add931b086

It seems that this bug is fixed by Bug 1482403, Can you please Try a Beta build or our Latest Nightly, you can find it Here: https://nightly.mozilla.org/
Status: UNCONFIRMED → NEW
Component: Untriaged → Web Painting
Ever confirmed: true
Flags: needinfo?(javier.rocamora)
Product: Firefox → Core
Hi, thanks for the help. I can confirm it works on nightly build. It sucks we have to wait till 11 december, but at least it's clear.

Cheers
Flags: needinfo?(javier.rocamora)
Thank you Javier, I will mark this as a duplicate for the Fixed issue.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1482403
You need to log in before you can comment on or make changes to this bug.