Choosing to Close the Tabs to the right only closes the last un-selected tabs from a carousel of selected and un-selected tabs

VERIFIED FIXED in Firefox 64

Status

()

defect
P5
normal
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: vlucaci, Assigned: jaws)

Tracking

(Blocks 1 bug)

Trunk
Firefox 65
Desktop
All
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox64 verified, firefox65 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 months ago
[Affected versions]:
- 65.0a1 (2018-11-02) 
- 64.0b6
- 63.0a1 (2018-07-05)

[Affected platforms]:
- Windows 10x64
- Ubuntu 16.04
- macOS 10.13.6


[Steps to reproduce]:
1. Launch FF
2. Open 8 tabs for example.
3. Select the first 4, leave the next 2 unselected, select the next one as well and leave the last one un-selected. 
4. Right click on any of the first 4 tabs .
5. Go to Close Tab options.

[Expected results]:
- Choosing to close the tabs to the right, should not close only the last un-selected tabs.

[Actual result]:
- The close tabs to the right option should close all the un-selected tabs to the right of the selected ones.

[Regression range]:
- This issue is not a regression.
(Reporter)

Updated

6 months ago
Blocks: 1458007
Priority: -- → P5

Comment 2

6 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a8459563981b
Close Tabs to the Right in a multiselect context should close all tabs to the right of the contextual tab that are not selected. r=dao
Assignee: nobody → jaws
Status: NEW → ASSIGNED

Comment 3

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a8459563981b
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Does this need a Beta uplift request?
Flags: needinfo?(jaws)
Comment on attachment 9023454 [details]
Bug 1504274 - Close Tabs to the Right in a multiselect context should close all tabs to the right of the contextual tab that are not selected. r?dao

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1477780

User impact if declined: Users may expect more tabs to close than what actually close.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Covered by many automated tests, this patch is a change in behavior as requested by users not as a result of an unintentional bug.

String changes made/needed: none
Flags: needinfo?(jaws)
Attachment #9023454 - Flags: approval-mozilla-beta?
Comment on attachment 9023454 [details]
Bug 1504274 - Close Tabs to the Right in a multiselect context should close all tabs to the right of the contextual tab that are not selected. r?dao

I guess if this is the direction we're going, we might as well be there in 64 directly.  Approved for 64.0b10.
Attachment #9023454 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Reporter)

Comment 8

5 months ago
Reproduced the issue with Nightly v 65.0a1 (2018-11-02) , on Win10x64.
Verified the fix with 63.0.1 on Win 10x64 ,macOS 10.12.6 and Ubuntu 16.04x64; can confirm the issue is no longer reproducible.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.