[Flexbox] Inconsistent mini-map display for flex- item with flex-shrink:2

RESOLVED DUPLICATE of bug 1504859

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1504859
6 months ago
5 months ago

People

(Reporter: paul.boiciuc, Unassigned)

Tracking

65 Branch
Unspecified
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0


[Affected OS-es]
- Windows 10
- Ubuntu 16.04
- Mac OS 10.13.6

[Affected Fx Version]
- Nightly (65.0a1 / 20181102100039)

[Not Affected Fx Version]
- DevEdition build (64.0b6/20181101155334)

STR:

1. Launch Firefox and navigate to https://developer.mozilla.org/en-US/docs/Web/CSS/flex-shrink
2. Enable the element inspector.
3. Select the <div> with flex-shrink: 2 from <div class "example-container">
4. Navigate to the Flexbox Inspector section and observe the minimap of the Flex Item. 
5. Now change the Flex Item sizing info display by selecting a different flex item of the container, and then go back to the initial flex item and observe the mini-map again.
6. Repeat step 5 and observe the mini-map of the flex item set to shrink again.

[AR]

The display of the mini-map of a flex-item set to shrink with value=2 is inconsistent. 
I could not reproduce this with 0 or 1 values set for flex-shrink. 

I've attached a screenshot of the different displays and a short video for better understanding.  

[ER]

The mini-map of any flex items set to shrink remains consistent while user changes views, if the properties of that specific item are not altered
(Reporter)

Comment 1

6 months ago
Blocks: 1478396
See Also: → 1504859
Priority: -- → P2
I think this was fixed by bug 1504859. I can't reproduce the problem anymore and looking at the video and STRs, I'm fairly certain the fix I made in bug 1504859 will have taken care of this issue too.

Feel free to re-open if it still occurs for you.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1504859
You need to log in before you can comment on or make changes to this bug.