Add tooltip message for refresh button in Storage Inspector section

VERIFIED FIXED in Firefox 67

Status

enhancement
P2
normal
VERIFIED FIXED
8 months ago
4 months ago

People

(Reporter: cfogel, Assigned: rfgo, Mentored)

Tracking

({good-first-bug})

Trunk
Firefox 67

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox63 wontfix, firefox64 wontfix, firefox65 wontfix, firefox66 wontfix, firefox67 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

8 months ago
[Affected versions]:
- 60.3.0esr , 63.0.1, 64.0b6, 65.0a1 (2018-11-04) 

[Affected platforms]:
- Win10, macOS10.13, 

[Steps to reproduce]:
1. Launch Firefox, access any webpage;
2. Open devTools - Storage Inspector tab;
3. Hover over the Refresh button in the inspector section;

[Expected result]:
- tooltip is displayed;

[Actual result]:
- no tooltip displayed;

[Regression range]:
- not a regression, the refresh button seems to not have a tooltip added from the start;
- pre-implementation: 2017-08-30;
- post-implementation: 2017-08-31;
Mentor: mratcliffe
Has STR: --- → irrelevant
Keywords: good-first-bug
Priority: -- → P2
Comment hidden (obsolete)
Assignee

Comment 2

4 months ago

Hi Cristi and Mike,

Since the bug was still on here, I went ahead and tried to tackle it. I've attached a screenshot below and wanted to request a code review.

Thanks.

https://pasteboard.co/I1Mqxpw.png

@Rainier That looks great... can you attach the patch?

Flags: needinfo?(mratcliffe) → needinfo?(rainier.f.go)
Assignee

Comment 4

4 months ago
Flags: needinfo?(rainier.f.go)

@rainier r+... would you like me to land your patch for you?

Flags: needinfo?(rainier.f.go)
Assignee: nobody → rainier.f.go
Assignee

Comment 8

4 months ago

Mike that would be great!

Flags: needinfo?(rainier.f.go)
Assignee

Comment 9

4 months ago

Since this is my first bug, just wanted to double check, in the future the mentors will be landing the patches right?

Attachment #9044732 - Attachment is obsolete: true

Comment 10

4 months ago
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b783af3efdd
Added tooltip to refresh button of storage inspector section. r=miker

I have queued it for landing, thanks for working on it!

(In reply to Rainier Go [:rfgo] from comment #9)

Since this is my first bug, just wanted to double check, in the future the mentors will be landing the patches right?

If you land lots of patches you can get permission to land things but for the moment it will be the mentors. You are best to ask them to land it for you because they may not know whether you have permission to land things yourself.

You can find more good first bugs here:
https://bugs.firefox-dev.tools/?easy&tool=all

Comment 12

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Confirmed the issue with Firefox 65.0a1 (2018-11-05) on Windows 10.
Fix verified with Firefox 67.0a1 (20190227163104), Windows 10 x64 and macOS 10.13.6.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.