Closed Bug 150475 Opened 20 years ago Closed 20 years ago

Backslash not recognised in IMG SRC path string

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows 2000
defect
Not set
trivial

Tracking

()

VERIFIED DUPLICATE of bug 32895

People

(Reporter: frank, Assigned: rods)

Details

Unix paths normally use a forward slash. Under windows a backslash is more 
common. Those users who enter a backslash for their <IMG SRC="xxxx"> path will 
not have the image correctly resolved under Mozilla. IE handles both, and 
Mozilla should as well, otherwise some pages may appear to be broken.
I think this bug is invalid, because RFC 2396 (Uniform Resource Identifiers
(URI): Generic Syntax) says "\" is not allowed within URIs. Furthermore
conversion of \ to / was *removed* as of bug 32895 because of this very reason.

*** This bug has been marked as a duplicate of 32895 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.