Closed Bug 1504852 Opened 2 years ago Closed 2 years ago

Turn off Content Blocking label is barely visible in the dark theme

Categories

(Firefox :: Site Identity, defect, P2)

Unspecified
All
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- verified

People

(Reporter: ehsan, Assigned: ewright)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [privacy65])

Attachments

(2 files)

Attached image Screenshot
Please see the screenshot.
Summary: Turn on Content Blocking label is barely visible in the dark theme → Turn off Content Blocking label is barely visible in the dark theme
Component: Theme → Site Identity and Permission Panels
Seems like this is specific to Linux, at least I can't reproduce on OSX. Erica, do you want to take a look at this whenever you have time? :)
Flags: needinfo?(ewright)
Keywords: regression
OS: Unspecified → Linux
Priority: -- → P2
Whiteboard: [privacy65]
Blocks: 1501986
Judging by the CSS, this should be an issue on Windows too. Set color: inherit to fix this.
OS: Linux → All
Assignee: nobody → ewright
Status: NEW → ASSIGNED
Flags: needinfo?(ewright)
In windows and linux, ensure that the text color inside the content blocking button is visible. Add 3 px of margin besode the icon to separate it from the text.
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6901bde94374
Turn off Content Blocking label color is visible in dark theme and icon is spaced from text. r=dao
https://hg.mozilla.org/mozilla-central/rev/6901bde94374
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
I verified this issue on mac OS, Ubuntu 16.04 and Windows 10, Nightly 65.0a1 (2018-11-07). Marking it accordingly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.