Closed Bug 1505222 Opened Last year Closed 11 months ago

One of the slides on http://idangero.us/swiper/ is all over the place. (perspective/preserve-3d)

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 2 open bugs, )

Details

Attachments

(6 files, 2 obsolete files)

See screenshot.

Seems like a nested gallery, and there's all sorts of crazy transforms in that page, so likely to be 3d transform related...

Works fine on non-WR.
Attached image WR screenshot.
Attached image non-WR
Priority: -- → P3
Summary: One of the slides on http://idangero.us/swiper/ is all over the place. → One of the slides on http://idangero.us/swiper/ is all over the place. (3d-transforms)
Attached file Standalone somewhat reduced version (obsolete) —

Slightly more reduced.

Attachment #9034864 - Attachment is obsolete: true

Looks like a perspective/preserve-3d interaction

Attachment #9034871 - Attachment is obsolete: true

Kvark says that emilio looked at perspective/preserve-3d most recently so assigning to him.

Assignee: nobody → emilio
Summary: One of the slides on http://idangero.us/swiper/ is all over the place. (3d-transforms) → One of the slides on http://idangero.us/swiper/ is all over the place. (perspective/preserve-3d)
Attachment #9035059 - Attachment mime type: text/plain → text/html
Flags: needinfo?(emilio)
Attached file Even more reduced.

The nested perspective is not needed, you just need to break the preserve-3d hierarchy.

Attachment #9036433 - Attachment mime type: text/plain → text/html
This fixes the bug because it makes the assumption that is made in:

  https://searchfox.org/mozilla-central/rev/bee8cf15c901b9f4b0c074c9977da4bbebc506e3/gfx/wr/webrender/src/display_list_flattener.rs#1274

hold. There's still a bunch of broken stuff in this regard, bugs incoming, but
it's probably worth landing this separately.
Blocks: 1504590
Attachment #9037100 - Attachment description: Bug 1505222 - Pass WR the preserve-3d-ness of the transformed frame instead of the perspective frame for perspective display items. → Bug 1505222 - Pass TransformStyle::Preserve3d to WebRender more often for perspective display items.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/2195f346d368
Pass TransformStyle::Preserve3d to WebRender more often for perspective display items. r=mattwoodrow
See Also: → 1521656
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/14992 for changes under testing/web-platform/tests
Flags: needinfo?(emilio)
Duplicate of this bug: 1517402
You need to log in before you can comment on or make changes to this bug.