Closed Bug 1505289 Opened Last year Closed 6 months ago

[remote-dbg-next] UX: Show previously connected devices in the sidebar

Categories

(DevTools :: about:debugging, defect, P1)

defect

Tracking

(firefox68 verified, firefox69 verified)

VERIFIED FIXED
Firefox 68
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: jdescottes, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

(Whiteboard: [remote-debugging-reserve])

Attachments

(7 files)

After discovering a device, when the device is disconnected, it simply disappears for the sidebar. 

STRs:
- connect via USB to Firefox for Android using new about:debugging
- device appears in the about:debugging sidebar
- disconnect the USB cable
=> Device suddenly disappears from the sidebar

It might be better to keep it a status "USB disconnected" as shown in the initial mockups at https://mozilla.invisionapp.com/share/F9IVW9WPG4W#/screens/297684721 (last screen, scroll down to the bottom).

This should probably be split between UX and implementation.
Summary: [remote-dbg-next] Show previously connected devices in the sidebar → [remote-dbg-next] UX: Show previously connected devices in the sidebar
Blocks: 1505725
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [remote-debugging-reserve]

The notion of unknown runtime is only relevant to aboutdebugging
As we will complexify this to handle unplugged devices, moving it to aboutdebugging seems reasonable.

Depends on D25779
To avoid confusion with connection/disconnection to runtimes, I use "unplugged" here. Makes sense for USB, might not make sense of we extend it to other connection types

Depends on D25782

Mocking adb instead of usb-runtimes module. Now that usb-runtimes has more logic, it makes sense to test it in our mochitests.

Depends on D25783

Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/88f37063a1ff
Move unknown runtime logic to aboutdebugging r=Ola,ladybenko
https://hg.mozilla.org/integration/autoland/rev/d864f9d6ce00
Show unplugged USB devices in about:debugging r=Ola,ladybenko,flod
https://hg.mozilla.org/integration/autoland/rev/3b2597e84231
Handle unplugged devices in telemetry middleware r=Ola,ladybenko
https://hg.mozilla.org/integration/autoland/rev/c3aea0459e5c
Mock adb instead of usb-runtimes in aboutdebugging tests r=Ola,ladybenko
https://hg.mozilla.org/integration/autoland/rev/5b4e9571635e
Add test for unplugged USB runtimes r=ladybenko
https://hg.mozilla.org/integration/autoland/rev/630d6ce9c7b0
Rename unknown (usb runtimes) to unavailable;r=Ola
Attached image image7.png

Adding a screenshot to show what unplugged USB devices now look like in the UI.

Duplicate of this bug: 1505725
Flags: qe-verify+
QA Contact: hani.yacoub

Verified as fixed on Firefox Nightly 69.0a1 (2019-05-29) and on Firefox 68.0b5 on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.