Closed Bug 1505460 Opened 2 years ago Closed 2 years ago

SeaMonkey general.useragent.override.github.com for GitHub

Categories

(SeaMonkey :: Preferences, enhancement)

SeaMonkey 2.49 Branch
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: grahamperrin, Unassigned)

Details

Mozilla/5.0 (X11; FreeBSD amd64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4 Lightning/5.4

At GitHub: 

> Please note that GitHub no longer supports old versions of Firefox.
> We recommend upgrading to the latest Safari, Google Chrome, or Firefox.

Non-working features include the Edit menu option for a comment.

Workaround: 

general.useragent.override.github.com

Re: <https://github.com/MrAlex94/Waterfox/pull/784> the following value seems to be good for Waterfox: 

Mozilla/5.0 (rv:60.0) Gecko/20100101 Firefox/60.0

For SeaMonkey, something else might be appropriate. 

Thanks
Personally I dislike adding user agents to the prefs. I rather tend to avoid sites and services which act like github. Glad that I use gitlab :)

But we need to at least mention it in the release notes. Same with google.

FRG
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: FreeBSD → All
Hardware: Unspecified → All
I think that works correctly.

This user agent works: 
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 SeaMonkey/2.53


This user agent don't work: 
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53

Only if activated in the settings "Advertise Firefox compatibility" there is this problem.

Firefox/56.0 is an old version.
SeaMonkey/2.53 is not an old version.

So both are displayed correctly.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
We may be able to increase the Firefox compatibility to a more recent value if the security patches of a later version have been integrated.

That is not completely correct, but not entirely wrong.

(In reply to Graham Perrin from comment #0)

At GitHub:

Please note that GitHub no longer supports old versions of Firefox.
We recommend upgrading to the latest Safari, Google Chrome, or Firefox.

Non-working features include the Edit menu option for a comment.

Workaround:

general.useragent.override.github.com

Mozilla/5.0 (rv:60.0) Gecko/20100101 Firefox/60.0

For SeaMonkey, something else might be appropriate.

bug #1242294 introduces "general.useragent.compatMode.firefox-exact", which drops all but Firefox/60 from UA string.

IOW, if user chooses this setting to be on, there is no need to site-specific override (until github will require FF/68 etc. :) )

The User-Agent string, being initially an application id, gradually evolved into "browser class" to which the application belongs.
Thus Chrome, Opera, Vivaldi belong to "Chrome class""; Firefox, Waterfox, Palemoon, SeaMonkey belongs to "Firefox class".
Certainly it is still not documented anywhere, and still even accompanied by various OS info, but it is de facto no longer an application id.

Personally, after I set common "general.useragent.override" to UA string just matching the correspond Firefox version (several years ago), I never see any issues with most common sites. The presence of SM in UA string says nothing useful for all the sites (except seamonkey addon site), just confuses some of them (github, google), and probably causes security stuffs to track your activity, since you use "strange/broken/hackish" software to access them.

You need to log in before you can comment on or make changes to this bug.