OPTION selected attribute is ignored

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 46845
15 years ago
13 years ago

People

(Reporter: david glance, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
From the spec:

"OPTION Attribute definitions

selected [CI]
When set, this boolean attribute specifies that this option is pre-selected."

In my own words:

selected is supposed to result in the option with the attribute being selected -
this only occurs on the first time the page is accessed. On refresh, the option
selected is the last one selected before the selected.

Steps to repro:

Using the form below, display an html page. Verify that "Lab 1" is selected.
Select "Lab 3" - refresh the page - "Lab 1" should now be selected - instead,
"Lab 3" is still selected.

<form>
<select NAME="select1" ID="select1"  >
   <option selected label="nLab 1" value="Lab 1">Lab 1 </option>
   <option  label="nLab 2" value="Lab 2">Lab 2 </option>
   <option  label="nLab 3" value="Lab 3">Lab 3 </option>
<input TYPE=SUBMIT VALUE="Go" >
</form>

Comment 1

15 years ago
This sounds like correct behavior.  The option with the SELECTED attribute will
be selected when the page is loaded initially, but form values are supposed to
be  remembered on Back/Forward/Reload; it's a feature.  If you wish to "forget"
the values, use Shift+Reload instead of standard reload.  If this behavior is
not documented, I guess that would be a sort of bug, but I have a feeling it is
(can't find it myself, though...).

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.