Closed Bug 1505849 Opened Last year Closed 11 months ago

Implement parser support for BigInt literals

Categories

(Core :: JavaScript Engine, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: wingo, Assigned: wingo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This bug takes :terpri's patch from bug 1456568, but makes some modifications and rebases it.


The patch on that bug makes the tokenizer allocate BigInts directly and has some rooting problems.  This patch changes the tokenizer to instead just record the characters comprising the bigint, and defers BigInt allocation to the parser.  In this way the BigInt is protected from GC as it can go onto something like an ObjectBox.  Also, for syntax parsing, we can avoid allocating the bigint at all.

Uploading for early review by :terpri.
Duplicate of this bug: 1456568
Keywords: checkin-needed
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56f220f7a98f
Implement parser support for BigInt literals r=terpri,jandem
Keywords: checkin-needed
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/56f220f7a98f
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.