CRL 'auto update' status does not change after editing in Preferences/Privacy & Securtiy/Validation

RESOLVED INVALID

Status

P3
normal
RESOLVED INVALID
17 years ago
2 years ago

People

(Reporter: pieter, Unassigned)

Tracking

1.0 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kerh-coz][psm-crl])

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

In "Preferences/Privacy & Securtiy/Validation"
managing CRLs, the chosen CRLs "auto update" atttibute as shown doesn't
correspond to its real value after that value has been changed.

Reproducible: Always
Steps to Reproduce:
1 In "Preferences/Privacy & Securtiy/Validation"
Press "Manage CRLs", a window pops up.
2-Press "Settings" of a selected CRL, a dialogue pops up. 
3-Change "Enable Automatic Update for this CRL" from either on to off, or vice
versa. Press "Okay" to close the dailogue.
4-The "Auto Update" attribute of the CRL in the list that has just been changed
has NOT changed accordingly.
5-Close "Manage CRL" window.
6-Now open "Mange CRL" window again, NOW the "Auto Update" attribute shows the
correct status.
 

Actual Results:  "Auto Update" attribute of the CRL in the list that has just
been changed has NOT changed accordingly. It only did after closing and
re-opening "Manage CRL" window.

Expected Results:  "Auto Update" attribute of the CRL in the list that has just
been changed SHOULD have changed accordingly.

Comment 1

17 years ago
Confirming. Workaround - closing and reopening the window causes the display to 
refresh.
Assignee: mstoltz → ssaux
Status: UNCONFIRMED → NEW
Component: Security: General → Client Library
Ever confirmed: true
Priority: -- → P3
Product: Browser → PSM
QA Contact: bsharma → junruh
Version: other → 2.3

Comment 2

16 years ago
Still happening.
Version: 2.3 → 2.4

Comment 3

15 years ago
Mass reassign ssaux bugs to nobody
Assignee: ssaux → nobody

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Comment 4

13 years ago
*** Bug 302298 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: nobody → kaie.bugs
QA Contact: junruh

Updated

13 years ago
Whiteboard: [kerh-coz]

Comment 5

12 years ago
still happening in SeaMonkey 1.0.7 and Firefox 1.5.0.9

Comment 6

12 years ago
same problem also observed for "Last Update" and "Next update" fields - they do not update right after CRL was updated, need to re-open the "Manage CRLs" dialog to observe changes.

Happens in seaMonkey 1.0.7 and Firefox 1.5.0.9

Do I need to file this as separate bug?

Comment 7

12 years ago
(In reply to comment #6)
> Happens in seaMonkey 1.0.7 and Firefox 1.5.0.9
> 
> Do I need to file this as separate bug?

No separate bug needed, this is shared code.
QA Contact: ui

Updated

10 years ago
Version: psm2.4 → 1.0 Branch

Updated

8 years ago
Assignee: kaie → nobody
Whiteboard: [kerh-coz] → [kerh-coz][psm-crl]
The "Revocation Lists" feature was removed in bug 867465.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 867465
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.