Closed Bug 1506054 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Remove test-helpers module from src once we can mock require calls directly

Categories

(DevTools :: about:debugging, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1510545

People

(Reporter: jdescottes, Unassigned)

References

Details

(Whiteboard: old-remote-debugging-ng-m3)

In Bug 1497917 we are introducing a module to add mocking support for a few classes. Ideally this should not have any impact on the source modules of aboutdebugging. However the DevTools loader currently does not support mocks. A RFC will be created to discuss this but in the meantime we create a test-helper module that is called from both src/ modules and from test/ files.

The goal of this bug is to cleanup the situation once we can set mocks directly in the DevTools loader.
Priority: -- → P3
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
No longer blocks: remote-debugging-ng-m3
Whiteboard: old-remote-debugging-ng-m3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1510545
No longer blocks: remote-debugging-ng-m2
You need to log in before you can comment on or make changes to this bug.