Update webrender to 56ffe6edc4c453a370784314194f9516af0a8950 (WR PR 3290)

RESOLVED FIXED in Firefox 65

Status

()

enhancement
P3
normal
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: kats, Assigned: lsalzman)

Tracking

(Blocks 2 bugs)

65 Branch
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

(Whiteboard: [gfx-noted], )

Attachments

(3 attachments)

+++ This bug was initially created as a clone of Bug #1506004 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/wrupdater/blob/master/try-latest-webrender.sh
WR @ commit 56ffe6edc4c453a370784314194f9516af0a8950 (servo/webrender#3290) on HG rev 2f1158e5e0ce:    https://treeherder.mozilla.org/#/jobs?repo=try&revision=e7476f779f2f7a2079674a5019d639eef803bf9a
Alias: wr-future-update
Assignee: nobody → lsalzman
Summary: Future webrender update bug → Update webrender to 56ffe6edc4c453a370784314194f9516af0a8950 (WR PR 3290)
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b106d4fc3338
Update webrender to commit 56ffe6edc4c453a370784314194f9516af0a8950 (WR PR #3290). r=kats
https://hg.mozilla.org/integration/autoland/rev/18305886b6be
Re-vendor rust dependencies. r=kats
https://hg.mozilla.org/integration/autoland/rev/e890f65d5127
Fuzz for fixed WebRender DWrote text render mode. r=kats
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1351116
Sorry, wrong bug...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
https://hg.mozilla.org/mozilla-central/rev/b106d4fc3338
https://hg.mozilla.org/mozilla-central/rev/18305886b6be
https://hg.mozilla.org/mozilla-central/rev/e890f65d5127
Status: NEW → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.