Closed Bug 1506360 Opened 10 months ago Closed 9 months ago

Firefox stores video cache although new cache is created for the same video and the old cache becomes useless but still takes space in Cache Folder

Categories

(Core :: Networking: Cache, defect)

63 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: www-mamide, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

When i play video in youtube for example


Actual results:

firefox stores cache of this video (dozens of files with a total of some megabytes) . Now when i close firefox and reopen it i play the same video and firefox store approximately the same amount of files and megabytes.

So the old cache still be present although it becomes useless.


Expected results:

i think firefox must clear the cache related to this video when it becomes useless for the user because it takes place for nothing.
Adding the component in order to involve the development team in reviewing this, as I'm not sure if it's a valid expected result or not.
Component: Untriaged → Networking: Cache
Product: Firefox → Core
Michal, can you take a look?
Flags: needinfo?(michal.novotny)
URLs of video segments on youtube change every time the page is reloaded, i.e. it's not the same resource. Firefox cannot know that the entries are no longer usable so they stay in the cache until they're evicted due to caching of some new content.
Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Flags: needinfo?(michal.novotny)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.