Closed Bug 1506417 Opened 2 years ago Closed 2 months ago

Intermittent Assertion failure: false (NS_SUCCEEDED(dbInfo->mThreadInfo.mThread->Dispatch(runnable.forget(), nsIEventTarget::DISPATCH_NORMAL))), at /builds/worker/workspace/build/src/dom/indexedDB/ActorsParent.cpp:12371

Categories

(Core :: Storage: IndexedDB, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: sg)

References

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell disabled])

Attachments

(2 files)

Filed by: cbrindusan [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=211041378&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/bgD8CWqAQ-OPQczqLnnl5w/runs/0/artifacts/public/logs/live_backing.log

14:30:38     INFO - TEST-START | /IndexedDB/key_valid.html
14:30:38     INFO - Closing window 4294967301
14:30:38     INFO - PID 777 | ++DOCSHELL 0x124bc7800 == 3 [pid = 780] [id = {d0bc0fcf-3569-7544-ad53-214b2386984d}]
14:30:38     INFO - PID 777 | ++DOMWINDOW == 8 (0x125d62c00) [pid = 780] [serial = 8] [outer = 0x0]
14:30:38     INFO - PID 777 | ++DOMWINDOW == 9 (0x1244d5c00) [pid = 780] [serial = 9] [outer = 0x125d62c00]
14:30:38     INFO - PID 777 | ++DOMWINDOW == 10 (0x125d52800) [pid = 780] [serial = 10] [outer = 0x125d62c00]
14:30:38     INFO - PID 777 | ++DOCSHELL 0x12460b800 == 1 [pid = 782] [id = {2d7c95e6-7481-064a-9db3-71e68b96071e}]
14:30:38     INFO - PID 777 | ++DOMWINDOW == 1 (0x11533c400) [pid = 782] [serial = 1] [outer = 0x0]
14:30:38     INFO - PID 777 | ++DOMWINDOW == 2 (0x11c5c5c00) [pid = 782] [serial = 2] [outer = 0x11533c400]
14:30:39     INFO - PID 777 | ++DOMWINDOW == 3 (0x124e06000) [pid = 782] [serial = 3] [outer = 0x11533c400]
14:30:41     INFO - PID 777 | [Parent 777, IPDL Background] WARNING: '!event', file /builds/worker/workspace/build/src/xpcom/threads/ThreadEventTarget.cpp, line 128
14:30:41     INFO - PID 777 | Assertion failure: false (NS_SUCCEEDED(dbInfo->mThreadInfo.mThread->Dispatch(runnable.forget(), nsIEventTarget::DISPATCH_NORMAL))), at /builds/worker/workspace/build/src/dom/indexedDB/ActorsParent.cpp:12371
14:30:41     INFO - PID 777 | #01: 2018-11-10 14:30:41.047 atos[784:9897] Metadata.framework [Error]: couldn't get the client port
14:30:41     INFO - PID 777 | #02: 0x030bb7d2 (in XUL) + 450
14:30:41     INFO - PID 777 | #03: 0x030bfaad (in XUL) + 301
14:30:41     INFO - PID 777 | #04: 0x030beb2f (in XUL) + 607
14:30:41     INFO - PID 777 | #05: 0x00121827 (in XUL) + 1975
14:30:41     INFO - PID 777 | #06: 0x00125807 (in XUL) + 39
14:30:41     INFO - PID 777 | #07: 0x00792e6d (in XUL) + 173
14:30:41     INFO - PID 777 | #08: 0x00741b47 (in XUL) + 71
14:30:41     INFO - PID 777 | #09: 2018-11-10 14:30:41.234 atos[786:9904] Metadata.framework [Error]: couldn't get the client port
14:30:41     INFO - PID 777 | #10: 2018-11-10 14:30:41.265 atos[788:9911] Metadata.framework [Error]: couldn't get the client port
14:30:41     INFO - PID 777 | #11: _pthread_body (in libsystem_pthread.dylib) + 131
14:30:41     INFO - PID 777 | Hit MOZ_CRASH(Aborting on channel error.) at /builds/worker/workspace/build/src/ipc/glue/MessageChannel.cpp:2658
14:30:41     INFO - PID 777 | #01: 0x0011e887 (in XUL) + 487
14:30:41     INFO - PID 777 | #02: 0x0079202f (in XUL) + 79
14:30:41     INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/BFsXH3apRk2B52sJtVvk9w/artifacts/public/build/target.crashreporter-symbols.zip
14:30:41     INFO - PID 777 | #03: 0x00760daa (in XUL) + 1450
14:30:41     INFO - PID 777 | #04: 0x0075de5c (in XUL) + 1292
14:30:41     INFO - PID 777 | #05: 0x00744262 (in XUL) + 338
14:30:41     INFO - PID 777 | #06: 0x00741b47 (in XUL) + 71
14:30:41     INFO - PID 777 | #07: 0x0074eb59 (in XUL) + 761
14:30:41     INFO - PID 777 | #08: _pthread_body (in libsystem_pthread.dylib) + 0
14:30:41     INFO - PID 777 | #09: _pthread_body (in libsystem_pthread.dylib) + 131
14:30:41     INFO - PID 777 | ** Unknown exception behavior: -2147483647
Duplicate of this bug: 1506375
Attachment #9024407 - Flags: review?(aryx.bugmail)
Attachment #9024407 - Flags: review?(aryx.bugmail) → review+
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f819af817f6d
Disable key_valid.html on mac debug for frequent failures. r=aryx
Keywords: leave-open
Whiteboard: [retriggered][stockwell disabled]
Duplicate of this bug: 1506651
Summary: Intermittent PID 777 | Assertion failure: false (NS_SUCCEEDED(dbInfo->mThreadInfo.mThread->Dispatch(runnable.forget(), nsIEventTarget::DISPATCH_NORMAL))), at /builds/worker/workspace/build/src/dom/indexedDB/ActorsParent.cpp:12371 → Intermittent Assertion failure: false (NS_SUCCEEDED(dbInfo->mThreadInfo.mThread->Dispatch(runnable.forget(), nsIEventTarget::DISPATCH_NORMAL))), at /builds/worker/workspace/build/src/dom/indexedDB/ActorsParent.cpp:12371

Hi Simon, currently there are no failures on any platform, but mac osx is still disabled. Maybe we should re-enable the test?

Flags: needinfo?(sgiesecke)
Assignee: nobody → sgiesecke
Status: NEW → ASSIGNED
Flags: needinfo?(sgiesecke)
Keywords: leave-open
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3c19659cb8d9
Remove old test exclusion. r=dom-workers-and-storage-reviewers,janv
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.