Closed Bug 1506873 Opened 10 months ago Closed Last month

Crash in mozilla::recordreplay::parent::ChildProcessInfo::ChildProcessInfo

Categories

(Core :: Web Replay, defect, P5, critical)

Unspecified
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox65 --- disabled
firefox66 --- disabled

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-9f671dac-6594-4f14-8b98-c28960181109.
=============================================================

Seen while looking at Mac crash stats: https://bit.ly/2qJy6w3. 12 installs/3 crashes, all on 10.13. No URLs, and it appears most of the crashes are startup crashes.

Top 6 frames of crashing thread:

0 XUL mozilla::recordreplay::parent::ChildProcessInfo::ChildProcessInfo toolkit/recordreplay/ipc/ChildProcess.cpp:523
1 XUL mozilla::recordreplay::parent::InitializeMiddleman toolkit/recordreplay/ipc/ChildProcess.cpp:45
2 XUL mozilla::dom::ContentProcess::Init dom/ipc/ContentProcess.cpp:286
3 XUL XRE_InitChildProcess toolkit/xre/nsEmbedFunctions.cpp:754
4 plugin-container main ipc/contentproc/plugin-container.cpp:50
5  @0x7fff76c21014 

=============================================================
This is probably fixed by bug 1506311 --- for a couple days web replay would break during startup on 10.13.
(In reply to Brian Hackett (:bhackett) from comment #1)
> This is probably fixed by bug 1506311 --- for a couple days web replay would
> break during startup on 10.13.

All the 10.13 crashes in this signature stopped, but there is one 10.14 signature from 20181114100226 which I think is after the patch landed.
Since my last comment, I see one crash on nightly, Build 20181120100045. MOZ_CRASH(ChildProcessInfo::LaunchSubprocess).

One 10.13 crash in this signature in the 20181228093007 build on nightly 66, but none since then. Will add the appropriate tracking flag.

Priority: -- → P5

No recent crashes, closing this one out as WFM.

Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.