Closed Bug 1506983 Opened 2 years ago Closed 2 years ago

Nightly forget setting of "Check for updates, but let you choose whether to install them" if renamed install folder

Categories

(Toolkit :: Application Update, defect)

65 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- wontfix

People

(Reporter: alice0775, Unassigned)

Details

Reproducible: always

Steps to reproduce:
1. Download Nightly build and extract to a local folder
2. Launch the Nightly
3. Select "Check for updates, but let you choose whether to install them" from option
4. Quit Nightly

5. Rename the installed folder name
6. Launch the Nightly with same profile
7. Observe the update option

Actual results:
Nightly forget setting of "Check for updates, but let you choose whether to install them".
The option is reverted to Automatically install updates (recommended).

And The build is automatically updated to the latest one unexpectedly.
And In the worst case, the user profile will be incompatible and user data may be lost.

Expected results:
The option settings should persist.
Blocks: update-prefs
No longer blocks: 1458314
We don't officially support running extracted Windows builds and there are also settings made in the registry that will be missing when using an extracted build.

I think this is going to be wontfix but I'll think about it a bit in case there is something we can do to make this better. If you can think of something that can make it better while still having a common config for this setting please post a comment and we'll consider it. Thanks!
umm.
Alternate proposal, Is it possible if provide a command line option like firefox.exe -disable_autoupdate.

When testing something like Bug 1506371, I want to prevent automatic updating immediately after startup, which is difficult under present circumstances(And the build is automatically updated to the latest one...  On the other hand, Policies.json completely invalidates the update function... ).
I suspect that the reason it is trying to update immediately is due to Firefox code that initiates a background check during startup. Could you try setting the app.update.checkInstallTime preference to false, launching Firefox, and then setting "Check for updates, but let you choose whether to install them"?
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #3)
> I suspect that the reason it is trying to update immediately is due to
> Firefox code that initiates a background check during startup. Could you try
> setting the app.update.checkInstallTime preference to false, launching
> Firefox, and then setting "Check for updates, but let you choose whether to
> install them"?

Thanks.
That setting met my purpose. 
Let close this as wontfix.
No longer blocks: update-prefs
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: dataloss, regression
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.