Closed Bug 15070 Opened 20 years ago Closed 20 years ago

Browser asks way too much for password for protected websites

Categories

(Core :: Networking, defect, P3, critical)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 6144

People

(Reporter: ed, Assigned: gagan)

References

()

Details

When I try to access a password protected site, I just keep getting the password
 dialog over and over again. It says 'Enter username for X realm "www.bla.com"',
 then each successive time it appends the 'X realm "www.bla.com"' part to the
end of the string.
I can't give the URL as I'm under NDA. If necessary I'll see if the site can set
 up another directory for this; no guarentee I can tho.
Does it work if you type in the password correctly the first time? I have tried
sites and it has worked. A bug has been filed about the appendation but I would
guess that is a UI issue only.
Severity: normal → critical
Component: Browser-General → Password Cache
I have had this problem for quite a while as well. Here's a test case:
http://www.thirdnipple.com/mozilla. Username and password are both "mozilla".
What happens for me is, it asks me for the username and password both twice,
and then relinquishes the page. If I hit reload, it challenges me for the
password twice again. On other pages I have visited (www.cin.ctp.com for
example, which I won't give you my password to) the number of times I'm
prompted for my password seems to be twice the combined number of total files
loaded (including html, images, stylesheets, possibly others).

In other words, you can access the website, just after much patience entering
passwords over and over again...
Assignee: don → gagan
Component: Password Cache → Necko
reassigning to necko since the UI is working OK.
I tried repeatedly entering the password at the original site I had problems at,
and it did eventually work, after a LOT of password typing.
Summary: Can't access password protected websites → Browser asks way too much for password for protected websites
Status: NEW → ASSIGNED
yes this is a known bug and I have a dup somewhere (under "make auth
persistent")
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 6144 ***
Resetting QA contact from leger.
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
Status: RESOLVED → VERIFIED
verified duplicate
You need to log in before you can comment on or make changes to this bug.