action and twisty icons no longer shown in about:performance

VERIFIED FIXED in Firefox 64

Status

()

defect
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: florian, Assigned: florian)

Tracking

({regression})

unspecified
mozilla65
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 verified, firefox65 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 months ago
This is a regression from bug 1196668.
(Assignee)

Updated

5 months ago
Assignee: nobody → florian
Status: NEW → ASSIGNED
Comment on attachment 9024998 [details] [diff] [review]
use a span element instead of an img element

Review of attachment 9024998 [details] [diff] [review]:
-----------------------------------------------------------------

Really sorry for the breakage. This looks good to me, thanks!

::: toolkit/components/aboutperformance/content/aboutPerformance.xhtml
@@ +166,5 @@
>        }
>        /* Ensure both pseudo elements have the same size and position. */
>        .action-icon::before, .action-icon::after {
> +        content: ""; /* The pseudo elements aren't generated without
> +                        specifying a value for this attribute. */

This is true for all elements, so I think the comment is not very useful. It just happens to be the case that we always have an "alt" content for the ::before pseudo-element for images in:

https://searchfox.org/mozilla-central/rev/007b66c1f5f7a1b9a900a2038652a16a020f010c/layout/style/res/html.css#643
Attachment #9024998 - Flags: review?(emilio) → review+

Comment 3

5 months ago
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f790f10bca33
use a span element instead of an img element for action and twisty icons, r=emilio.

Comment 4

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f790f10bca33
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
(Assignee)

Comment 5

5 months ago
Comment on attachment 9024998 [details] [diff] [review]
use a span element instead of an img element

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1506105

User impact if declined: The twisty icons in about:performance won't be visible in Firefox 64, due to a merge conflict.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): We tried to uplift the patch from bug 1506105 to beta, but the patch failed to apply because the patch from this bug landed in the middle on Nightly. I tried to rebase the patch by applying the CSS changes from here. It turns out this broke the twisty images. Uplifting the change at https://hg.mozilla.org/mozilla-central/rev/f790f10bca33#l1.37 fixes them. At this point we could as well uplift the rest of this patch to beta to have the code in the same shape on beta and central.

String changes made/needed: none
Attachment #9024998 - Flags: approval-mozilla-beta?
Comment on attachment 9024998 [details] [diff] [review]
use a span element instead of an img element

[Triage Comment]
Uplifts the remaining half of this patch to Beta (the first half was already landed in bug 1506105) to fix missing twisty icons in about:performance. Approved for 64.0b13.
Attachment #9024998 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+

Comment 8

5 months ago
Hi,

I checked and couldn't reproduce the issue on the latest Beta 64.0b13 Build ID:20181126173133 and Nightly 65.0a1 Build ID:20181127220131 both on Win10 x64 and macOS 10.11. Marking as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.