Default values ignore for xml attributes

VERIFIED DUPLICATE of bug 69799

Status

()

Core
XML
VERIFIED DUPLICATE of bug 69799
16 years ago
14 years ago

People

(Reporter: Jay Knight, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla seems to ignore default values for attributes given in a dtd.  For
instance  if a dtd contained

<!ATTLIST element attribute CDATA "default">

and a corresponding xml doc contained

<element />

Mozilla should see that the same as

<element attribute="default"/>

This seems like the desired behavior, but may go against w3c's recomendation. 
IE does it, and  XML::LibXML in perl has a $parser->complete_attribute() option
that you can set to do it either way.

*** This bug has been marked as a duplicate of 69799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: petersen → rakeshmishra
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.