ArVrGarage.nz renders weird in Firefox 64

RESOLVED FIXED in Firefox 65

Status

()

defect
P2
normal
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: cpearce, Assigned: kvark)

Tracking

(Blocks 1 bug, {regression})

unspecified
mozilla65
Unspecified
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 disabled, firefox65 fixed)

Details

()

Attachments

(2 attachments)

STR:
1. Open http://www.arvrgarage.nz/ in Firefox 64 (currently in beta)
2. Wait for it to load...
3. Observe weird rendering of the backdrop behind the "The Garage" div.

This appears to have regressed in 64, as the site displays correctly in 63 Release.
This bug only repro's when WebRender is enabled, so triaging appropriately.
Component: Layout → Graphics: WebRender
Priority: -- → P2
mozregression --good 2018-08-01 --bad 2018-11-14 --pref gfx.webrender.all:true -a http://www.arvrgarage.nz/
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=87ae93caad9b0c48edaf349633c275e4e0059e9e&tochange=e088bb62f286425a30a925fc3355eb40c92f79c1

mozregression --repo mozilla-inbound --good 1cae5a527a4b --bad 6807afe94107 --pref gfx.webrender.all:true -a http://www.arvrgarage.nz/
> 5:47.24 INFO: Last good revision: be6801cdeb537afa655bbd67d12ead8dc01c6c38
> 5:47.25 INFO: First bad revision: 302dcd8139426cfe25b9d2685800809c2d603658
> 5:47.25 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=be6801cdeb537afa655bbd67d12ead8dc01c6c38&tochange=302dcd8139426cfe25b9d2685800809c2d603658

> 302dcd813942	Andrew Osmond — Bug 1485420 - Part 2. Make ClipManager trim clip chains which can be merged with the display item. r=mstange
> a3ea43b5e6d8	Andrew Osmond — Bug 1485420 - Part 1. Expose WebRender bindings to merge a clip rect with a display item. r=mstange

This could be a duplicate of bug 1499015.
mozregression --find-fix --bad 2018-11-14 --good 2018-11-19 --pref gfx.webrender.all:true -a http://www.arvrgarage.nz/
> 11:50.36 INFO: First good revision: 669cd919724934a05579ed2e561d04dedd11e93a
> 11:50.36 INFO: Last bad revision: e58fd91eddcdbdf00c8a1902026c1d4fe0845396
> 11:50.36 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e58fd91eddcdbdf00c8a1902026c1d4fe0845396&tochange=669cd919724934a05579ed2e561d04dedd11e93a

> 669cd9197249	WR Updater Bot — Bug 1507848 - Update webrender to commit 5609676e166f939fcf1a4141c5b9cb715b68f1d9 (WR PR #3315). r=kats

https://github.com/servo/webrender/pull/3315
Status: NEW → RESOLVED
Closed: 8 months ago
Depends on: 1507848
Resolution: --- → FIXED
Assignee: nobody → dmalyshau
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.