Closed Bug 1507475 Opened Last year Closed Last year

[Wayland] Crash when display is changed

Categories

(Core :: Widget: Gtk, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Description of problem:
Firefox-wayland crashes on display switch. I have two displays one for standing, second for sitting. Switching display through gnome-control-center causes firefox-wayland crash.

Version-Release number of selected component (if applicable):
firefox-63.0.1-5.fc29.x86_64
firefox-wayland-63.0.1-5.fc29.x86_64

How reproducible:
* Attach 2 displays A and B
* Disable  display B
* Start firefox-wayland
* run gnome-control-center Display settings
* disable display A and enable display B, apply
* -> Firefox-wayland crash

Steps to Reproduce:
* Attach 2 displays A and B
* Disable  display B
* Start firefox-wayland
* run gnome-control-center Display settings
* disable display A and enable display B, apply
* -> Firefox-wayland crash

Actual results:
Firefox-wayland crash

Expected results:
Application should not crash. Windows should be placed on newly activated display

Additional info:
Default Firefox using Xwayland works normally.

Downstream bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1647776
Assignee: nobody → stransky
It's because moz_container_init() is called and puts container to data field at registry. Then wl_output is called (monitor change) and when the container is already deleted we're accessing freed data.

A solution may be to create one global registry wayland object and don't query registry in particular modules.
We need to call wl_display_get_registry() only once and use the object globally.
Keywords: checkin-needed
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bafd708f5788
[Wayland] Implement global wayland registry, r=jhorak
Keywords: checkin-needed
Thanks, there's an updated one.
Flags: needinfo?(stransky)
Keywords: checkin-needed
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca9f1be1f8e8
[Wayland] Implement global wayland registry, r=jhorak
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ca9f1be1f8e8
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
See Also: → 1527556
You need to log in before you can comment on or make changes to this bug.