Crashing in creating profiles- [NEW] in profile manager

VERIFIED DUPLICATE of bug 15261

Status

defect
P3
major
VERIFIED DUPLICATE of bug 15261
20 years ago
3 years ago

People

(Reporter: agracebush, Assigned: sspitzer)

Tracking

Trunk
All
Other

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:
1. Delete .mozilla directory
2. ./apprunner -installer
3. create new profile/ or migrate POP profile

Actual results: Crash
Console messages from start to finish:
Registered Ok
*** Registering html library
RegisterSelf([xpconnect wrapped nsIComponentManager],[xpconnect wrapped
nsIFileSpec],rel:nsSample.js,text/javascript)
RegisterSelf done
got a request-------------------------> pressed new to create new profile
run LoadDetectorsMenu()
got a request-------------------------> pressed next in CreateProfileWizard
nsProfile::~nsProfile()
Segmentation fault

Expected results: Profile created, migrated
Next time in profile manager should see created profile, migrated profile
Note** profiles listed in .mozilla directory but not in ProfileManager

Linux only so far build 1999092808

Note, IMAP profile migrated successfully and I was able to successfully use
apprunner
Assignee: selmer → racham
Bhuvan, take a look at this.  Somebody probably memory handling underneath us
again.
OS: Linux → other
Hardware: PC → All
This is happening on all platforms. Migration is possible on Win32 - both IMAP
and POP. On Mac (14600) apprunner window actually opened before the crash after
a migration.
Create new profile is not working
Severity: normal → major
Status: NEW → ASSIGNED
Target Milestone: M11
Summary: Linux-Crashing in creating profiles, migrating POP profiles → Crashing in creating profiles, migrating POP profiles
changed summary line
Assignee: racham → sspitzer
Status: ASSIGNED → NEW
re-assigning to me.

I just made a whole bunch of changes in that code, and I'll take a look at this.
From the talkback report- incident id 14001062
 Call Stack:    (Signature = ld-linux.so.2 + 0x6e36 (0x40006e36) cdf4a972)

   ld-linux.so.2 + 0x6e36 (0x40006e36)


   ld-linux.so.2 + 0x8e3d (0x40008e3d)


   libc.so.6 + 0xd88a6 (0x402a28a6)


   ld-linux.so.2 + 0xa12b (0x4000a12b)


   libc.so.6 + 0xd89fd (0x402a29fd)


   libdl.so.2 + 0x1058 (0x4016a058)


   ld-linux.so.2 + 0xa12b (0x4000a12b)


   libdl.so.2 + 0x1608 (0x4016a608)


   libdl.so.2 + 0x101d (0x4016a01d)


   libnspr3.so + 0xf033 (0x4011a033)


   libxpcom.so + 0x569c2 (0x400e59c2)


   libxpcom.so + 0x52842 (0x400e1842)


   libxpcom.so + 0x506b3 (0x400df6b3)


   libxpcom.so + 0x50a21 (0x400dfa21)


   libxpcom.so + 0x55498 (0x400e4498)


   libxpcom.so + 0x55d1f (0x400e4d1f)


   libxpcom.so + 0x56244 (0x400e5244)


   libappcores.so + 0x6925 (0x410dc925)


   apprunner + 0x2560 (0x0804a560)


   apprunner + 0x2987 (0x0804a987)


   libc.so.6 + 0x17cb3 (0x401e1cb3)



 Registers:
accepting.  marking all milestone 11.
Summary: Crashing in creating profiles, migrating POP profiles → Crashing in creating profiles- [NEW] in profile manager
changing summary line. POP profiles are migrating.
I can consistently crash using apprunner -installer to bring up ProfileManager
and choose [NEW] button to create an additional 5.0 profile. Profile gets
created but seamonkey is not launched. This happens on Win and Linux M10
candidates but is ok on Mac M10 candidate (build 1999100120)
creating a new profile (from -installer) is a known bug.
we're crashing in the JS code.

mccabe is looking into that one.

I'm looking into the pop migration crash today.

I'll look
since pop migration isn't crashing anymore, this is now a duplicate of 15261.

*** This bug has been marked as a duplicate of 15261 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.