Closed Bug 1507786 Opened 1 year ago Closed 1 year ago

Assertion failure: entryStack == exitStack, at /js/src/jit/arm64/vixl/MozSimulator-vixl.cpp:277

Categories

(Core :: Javascript: WebAssembly, defect, P2)

ARM64
Unspecified
defect

Tracking

()

RESOLVED DUPLICATE of bug 1507785
Tracking Status
firefox65 --- affected

People

(Reporter: bbouvier, Assigned: lth)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [arm64:m3])

Attachments

(2 files)

The following program crashes on a debug optimized ARM 64 bits build with arguments --no-wasm-ion a5ecb28afc374c14bfeab2a998fc01e3.js:
calling: func_0
   result: -1125899906842624
calling: func_1
calling: func_2_invoker
calling: func_4
   result: 1099511627776
calling: func_4_invoker
calling: func_6_invoker
calling: func_8
calling: func_8_invoker
calling: func_10
   result: NaN
calling: func_13
   result: 18446744073709552000
calling: func_16_invoker
calling: func_18
   result: 33554432
calling: func_18_invoker
calling: func_20
calling: func_20_invoker
calling: func_22_invoker
calling: func_24_invoker
calling: func_26_invoker
calling: func_28_invoker
calling: func_32
   result: 39
calling: func_33_invoker
calling: func_37_invoker
calling: func_40_invoker
calling: func_42_invoker
calling: func_44_invoker
calling: func_46_invoker
calling: func_48_invoker
calling: func_50
   result: 0
calling: func_50_invoker
calling: func_53
   result: -4
calling: func_54_invoker
calling: func_57_invoker
calling: func_59_invoker
calling: func_61
   exception: RuntimeError: unreachable executed
calling: func_62
   result: 65428
calling: func_63
   result: 127
calling: func_64_invoker
calling: func_66
calling: func_67
   result: 0
calling: func_68
calling: func_70
   result: 0
calling: func_71
   result: 30565
calling: func_73
calling: func_73_invoker
calling: func_78
   result: 4294967296
calling: func_79_invoker
calling: func_81_invoker
calling: func_84_invoker
calling: func_86
   result: 0
calling: func_87_invoker
calling: func_89_invoker
calling: func_94_invoker
calling: func_98_invoker
Assertion failure: entryStack == exitStack, at /home/ben/code/mozilla-inbound/js/src/jit/arm64/vixl/MozSimulator-vixl.cpp:277
Flags: needinfo?(lhansen)
Assignee: nobody → lhansen
Blocks: Fennec-ARM64
Status: NEW → ASSIGNED
Flags: needinfo?(lhansen)
Priority: -- → P2
Hardware: Unspecified → ARM64
[arm64:m3] because this assertion failure should probably block ARM64 Fennec from riding the trains.
Whiteboard: [arm64:m3]
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1507785
You need to log in before you can comment on or make changes to this bug.